summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-30 22:34:31 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-30 22:55:40 +0100
commit27702248955f48d3c6cb6a4cd438cd4c6626a79d (patch)
treeccd3460a5d3b28ba2ad37fecb3b9e893627652cf /dev-python/pygments/pygments-2.11.0.ebuild
parentdev-python/wcag-contrast-ratio: New dep of pygments, v0.9 (diff)
downloadgentoo-27702248955f48d3c6cb6a4cd438cd4c6626a79d.tar.gz
gentoo-27702248955f48d3c6cb6a4cd438cd4c6626a79d.tar.bz2
gentoo-27702248955f48d3c6cb6a4cd438cd4c6626a79d.zip
dev-python/pygments: Bump to 2.11.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pygments/pygments-2.11.0.ebuild')
-rw-r--r--dev-python/pygments/pygments-2.11.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pygments/pygments-2.11.0.ebuild b/dev-python/pygments/pygments-2.11.0.ebuild
new file mode 100644
index 000000000000..0beaa1b09225
--- /dev/null
+++ b/dev-python/pygments/pygments-2.11.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1 bash-completion-r1
+
+MY_P=${P^}
+DESCRIPTION="Pygments is a syntax highlighting package written in Python"
+HOMEPAGE="
+ https://pygments.org/
+ https://github.com/pygments/pygments/
+ https://pypi.org/project/Pygments/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${PN^}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/wcag-contrast-ratio[${PYTHON_USEDEP}]
+ virtual/ttf-fonts
+ )"
+
+distutils_enable_sphinx doc
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newbashcomp external/pygments.bashcomp pygmentize
+}