summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-04 09:34:28 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-04 09:34:28 +0100
commit1df3cf378b95f59d76c98bfca0f23648cbabce2b (patch)
treea62f0a4027d854f0165c74cc09de28068919a8e9 /dev-python/pygments
parentapp-editors/dhex: Fix for ncurses[tinfo] (diff)
downloadgentoo-1df3cf378b95f59d76c98bfca0f23648cbabce2b.tar.gz
gentoo-1df3cf378b95f59d76c98bfca0f23648cbabce2b.tar.bz2
gentoo-1df3cf378b95f59d76c98bfca0f23648cbabce2b.zip
dev-python/pygments: Fix byte decoding in py3
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=564478 Package-Manager: portage-2.2.25 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pygments')
-rw-r--r--dev-python/pygments/files/2.0.2-bytes-decode.patch16
-rw-r--r--dev-python/pygments/pygments-2.0.2-r2.ebuild (renamed from dev-python/pygments/pygments-2.0.2-r1.ebuild)1
2 files changed, 17 insertions, 0 deletions
diff --git a/dev-python/pygments/files/2.0.2-bytes-decode.patch b/dev-python/pygments/files/2.0.2-bytes-decode.patch
new file mode 100644
index 000000000000..35f2e26aaca5
--- /dev/null
+++ b/dev-python/pygments/files/2.0.2-bytes-decode.patch
@@ -0,0 +1,16 @@
+ pygments/formatters/img.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/pygments/formatters/img.py b/pygments/formatters/img.py
+index db5bee3..12d53cd 100644
+--- a/pygments/formatters/img.py
++++ b/pygments/formatters/img.py
+@@ -84,7 +84,7 @@ class FontManager(object):
+ if not exit:
+ lines = out.splitlines()
+ if lines:
+- path = lines[0].strip().strip(':')
++ path = lines[0].decode().strip().strip(':')
+ return path
+
+ def _create_nix(self):
diff --git a/dev-python/pygments/pygments-2.0.2-r1.ebuild b/dev-python/pygments/pygments-2.0.2-r2.ebuild
index b2de0150b71c..adef7afa90f1 100644
--- a/dev-python/pygments/pygments-2.0.2-r1.ebuild
+++ b/dev-python/pygments/pygments-2.0.2-r2.ebuild
@@ -36,6 +36,7 @@ S="${WORKDIR}/${MY_P}"
PATCHES=(
"${FILESDIR}"/${PV}-shell-injection-backport.patch
"${FILESDIR}"/${PV}-shell-injection-backport2.patch
+ "${FILESDIR}"/${PV}-bytes-decode.patch
)
python_compile_all() {