summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-04-24 20:21:40 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-04-24 20:23:07 +0300
commit7ba9c69ea707e01735dff1f2ceda04947d7b709d (patch)
tree7f53e9fcd1f8ee9883501138ee8752e38f1877ee /dev-python/pygments
parentdev-python/pygments: fix doc generation (diff)
downloadgentoo-7ba9c69ea707e01735dff1f2ceda04947d7b709d.tar.gz
gentoo-7ba9c69ea707e01735dff1f2ceda04947d7b709d.tar.bz2
gentoo-7ba9c69ea707e01735dff1f2ceda04947d7b709d.zip
dev-python/pygments: add 2.12.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pygments')
-rw-r--r--dev-python/pygments/Manifest1
-rw-r--r--dev-python/pygments/pygments-2.12.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pygments/Manifest b/dev-python/pygments/Manifest
index a6c3f8ed0b90..b096c4cec670 100644
--- a/dev-python/pygments/Manifest
+++ b/dev-python/pygments/Manifest
@@ -1 +1,2 @@
DIST Pygments-2.11.2.tar.gz 4206258 BLAKE2B d9b7ac03ab564051df8eebf390586387d824584f5485eb6af2048cec181412fe2812409251c9c042421125a2579d9ac6de4006c1c0de025ed7b010482482b9f9 SHA512 606ff0c35fa47882f4c5c3794827132e1ee6ccbb4895ae858f9c93ea0c92b73163c9f4d630b51a8bb782ba0b4944a66d1059ad5d017d3191a0a5b30c1e5b8f9f
+DIST Pygments-2.12.0.tar.gz 4282017 BLAKE2B 9ad241d5bcafe59057e9495edb75468e6fa74d150f2d3266590a5a567a7df8ce2ef4ea18f90a8ab83e2fb84993fcf00dec12b04dd968f4c516b8339c49aecc08 SHA512 70bbfaefeb34f9afb5d74aa924ac3da4a913d1c7f607c0b3f80b6cd25c88a8996e516a689062bf2009c472b29999e309eb044f0f427fa1ea8479bf921b51c524
diff --git a/dev-python/pygments/pygments-2.12.0.ebuild b/dev-python/pygments/pygments-2.12.0.ebuild
new file mode 100644
index 000000000000..3ae83b82e8ae
--- /dev/null
+++ b/dev-python/pygments/pygments-2.12.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1 bash-completion-r1
+
+MY_P=${P^}
+DESCRIPTION="Pygments is a syntax highlighting package written in Python"
+HOMEPAGE="
+ https://pygments.org/
+ https://github.com/pygments/pygments/
+ https://pypi.org/project/Pygments/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${PN^}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/wcag-contrast-ratio[${PYTHON_USEDEP}]
+ virtual/ttf-fonts
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.11.2-fix-docs-relative.patch"
+)
+
+distutils_enable_sphinx doc \
+ dev-python/wcag-contrast-ratio
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newbashcomp external/pygments.bashcomp pygmentize
+}