summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Seren <guillaumeseren@gmail.com>2019-12-27 20:52:00 +0100
committerSebastian Pipping <sping@gentoo.org>2019-12-27 22:32:22 +0100
commitca5a774d8febbaceeb696fc51dd88d0efb6e0a7b (patch)
tree6d44ba035010c7bb9116370b5f374d0993a2bcda /dev-python/pygments
parentapp-misc/rbutil: Drop unnecessary subslot Qt operators (diff)
downloadgentoo-ca5a774d8febbaceeb696fc51dd88d0efb6e0a7b.tar.gz
gentoo-ca5a774d8febbaceeb696fc51dd88d0efb6e0a7b.tar.bz2
gentoo-ca5a774d8febbaceeb696fc51dd88d0efb6e0a7b.zip
dev-python/pygments: Add version bump 2.5.2
Signed-off-by: Guillaume Seren <guillaumeseren@gmail.com> Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.79, Repoman-2.3.16
Diffstat (limited to 'dev-python/pygments')
-rw-r--r--dev-python/pygments/Manifest1
-rw-r--r--dev-python/pygments/pygments-2.5.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pygments/Manifest b/dev-python/pygments/Manifest
index 275757f20411..9378b39aa4f5 100644
--- a/dev-python/pygments/Manifest
+++ b/dev-python/pygments/Manifest
@@ -1,3 +1,4 @@
DIST Pygments-2.2.0.tar.gz 2113944 BLAKE2B 58d5f2fa0e6d97f5b7d7a17314b82ef219f23b72f8da49b4f8ce9b892d54ffbc1b490e87e87efe8d727dab297f775d0d8abfc4a31a734c5a7f8df885e5eda82f SHA512 cc0a4f73e19fa6cbf46314de2e809460c807c631e39ba05cbe5edb5f40db1a687aafcd9715585a0ed45f791710eb6038305e273f282f8682df76f30e63710b29
DIST Pygments-2.3.1.tar.gz 3124216 BLAKE2B 99a5f96a2d2f9deb1a6b6ad94a21ab7f517cde47b1e91b67ce594732004cf99db51b1240e0270473f87f5d8a435172545b9fa3449a2ddc113faf5aaef6c34f73 SHA512 2c36cb42f8dd62e04b7664b5e87f951a8428ccbb6dbe5b5b43d8c7e6923ada0ab55a231bb8e9ed79eb5a85344ed64d3acc8e7bc991ab1f49c58eb612b8002c1e
DIST Pygments-2.4.2.tar.gz 9405880 BLAKE2B 20a955fce2b06ab12bd4ede4da9308f1cc5f2286391146fd83f3d598cd38ae66e7df3c1d779c8f6f5de67ad92d032ff02fef8f41141edb007e2f24d3586d82e6 SHA512 c8f378700e99d9e5701ac7e27363921dbabab50a910686aafda1e016c813e99915fcfeed8298323b9b681b3d81f4265ab9a5bb75b8cdff0668c9eff745337b66
+DIST Pygments-2.5.2.tar.gz 20263984 BLAKE2B fab5d11458bcb3bd9a825026f119c0bde6f672b00704f3d5db24ce050b959f0c1a34544642fc1b5911f6ae12a9b595a2cbedadc791d6a3e8c83da1a1add60471 SHA512 d6715ca26cdb68d4c771bb530b2395805025c14c78d9099b033d3410ea239c41033fb611e43e39cbaa4ac38078a09324d8cfde42269129be0a096dcc13586859
diff --git a/dev-python/pygments/pygments-2.5.2.ebuild b/dev-python/pygments/pygments-2.5.2.ebuild
new file mode 100644
index 000000000000..c74e33c5dd70
--- /dev/null
+++ b/dev-python/pygments/pygments-2.5.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy pypy3 )
+
+inherit distutils-r1 bash-completion-r1
+
+MY_PN="Pygments"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Pygments is a syntax highlighting package written in Python"
+HOMEPAGE="https://pygments.org/ https://pypi.org/project/Pygments/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ virtual/ttf-fonts
+ )"
+
+distutils_enable_sphinx doc
+
+python_test() {
+ cp -r -l tests "${BUILD_DIR}"/ || die
+ pytest "${BUILD_DIR}"/tests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newbashcomp external/pygments.bashcomp pygmentize
+}