summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2020-04-23 12:48:18 +0700
committerAndrey Grozin <grozin@gentoo.org>2020-04-23 12:48:18 +0700
commit95c16107739e71bc5934f354f3c76dda7306b980 (patch)
treefa4fa8d91efef950309353d9c9653212b6161fc2 /dev-python/pygpgme/pygpgme-0.3-r2.ebuild
parentdev-perl/Algorithm-Munkres: -r bump for EAPI7 (diff)
downloadgentoo-95c16107739e71bc5934f354f3c76dda7306b980.tar.gz
gentoo-95c16107739e71bc5934f354f3c76dda7306b980.tar.bz2
gentoo-95c16107739e71bc5934f354f3c76dda7306b980.zip
dev-python/pygpgme: add python3_8
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'dev-python/pygpgme/pygpgme-0.3-r2.ebuild')
-rw-r--r--dev-python/pygpgme/pygpgme-0.3-r2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pygpgme/pygpgme-0.3-r2.ebuild b/dev-python/pygpgme/pygpgme-0.3-r2.ebuild
new file mode 100644
index 000000000000..feeddfd94ea0
--- /dev/null
+++ b/dev-python/pygpgme/pygpgme-0.3-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="A Python wrapper for the GPGME library"
+HOMEPAGE="https://launchpad.net/pygpgme"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="app-crypt/gpgme"
+RDEPEND="${DEPEND}"
+
+python_configure_all() {
+ append-cflags $(gpgme-config --cflags)
+}