summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-08-22 01:20:38 +0200
committerDavid Seifert <soap@gentoo.org>2020-08-22 01:20:38 +0200
commit35bd9fb96d8171607f4b6cf84aaebac12d2a6b18 (patch)
treebd0a3708df9b73ed611229025ff894ea26d53ab7 /dev-python/pygraphviz/pygraphviz-1.6.ebuild
parentdev-python/doctest-ignore-unicode: Add python 3.9 (diff)
downloadgentoo-35bd9fb96d8171607f4b6cf84aaebac12d2a6b18.tar.gz
gentoo-35bd9fb96d8171607f4b6cf84aaebac12d2a6b18.tar.bz2
gentoo-35bd9fb96d8171607f4b6cf84aaebac12d2a6b18.zip
dev-python/pygraphviz: Version bump to 1.6
Bug: https://bugs.gentoo.org/732224 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/pygraphviz/pygraphviz-1.6.ebuild')
-rw-r--r--dev-python/pygraphviz/pygraphviz-1.6.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pygraphviz/pygraphviz-1.6.ebuild b/dev-python/pygraphviz/pygraphviz-1.6.ebuild
new file mode 100644
index 000000000000..e53d8c412382
--- /dev/null
+++ b/dev-python/pygraphviz/pygraphviz-1.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for the Graphviz Agraph data structure"
+HOMEPAGE="https://pygraphviz.github.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+# Note: only C API of graphviz is used, PYTHON_USEDEP unnecessary.
+RDEPEND="media-gfx/graphviz"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-arch/unzip
+ dev-lang/swig:0
+ test? ( dev-python/doctest-ignore-unicode[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests nose
+
+PATCHES=( "${FILESDIR}"/${PN}-1.5-docs.patch )
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ swig -python pygraphviz/graphviz.i || die
+}
+
+python_test() {
+ nosetests -c setup.cfg -x -v "${BUILD_DIR}"/lib/pygraphviz || die
+}
+
+python_install_all() {
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+
+ distutils-r1_python_install_all
+}