summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2019-02-14 06:34:04 -0500
committerAaron W. Swenson <titanofold@gentoo.org>2019-02-14 06:34:09 -0500
commitd1fffdd56d8db669e24c2c45616434a20322799b (patch)
treeaaee4b955a2dcb3c0a3e8e2a57553d0a697f192a /dev-python/pygresql
parentmedia-plugins/gst-plugins-libnice: bump to 0.1.15 (diff)
downloadgentoo-d1fffdd56d8db669e24c2c45616434a20322799b.tar.gz
gentoo-d1fffdd56d8db669e24c2c45616434a20322799b.tar.bz2
gentoo-d1fffdd56d8db669e24c2c45616434a20322799b.zip
dev-python/pygresql: Bump to 5.0.6
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-python/pygresql')
-rw-r--r--dev-python/pygresql/Manifest1
-rw-r--r--dev-python/pygresql/pygresql-5.0.6.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pygresql/Manifest b/dev-python/pygresql/Manifest
index 62d3219b7571..413fdbc0e3dd 100644
--- a/dev-python/pygresql/Manifest
+++ b/dev-python/pygresql/Manifest
@@ -1 +1,2 @@
DIST PyGreSQL-5.0.4.tar.gz 637569 BLAKE2B 3f7bddb8b5e455ca4f181d254d4d125b89a64d7aaa1440b9ab5d916c395b9d93fc9814269992c134b6fd8a81f436752dbe4d7c06125e683a5257361d428c6a6f SHA512 f177ca3b023c007dafe80369b86a1742ff334137e493c3c19ac8bda0181d2543cd2431b8ab8d2d43f30d681121324bc4f236a9ebbddf1e927b071db7c9b34ea6
+DIST PyGreSQL-5.0.6.tar.gz 648481 BLAKE2B 7e1d96b5c09a3d2f0e412504be27fcfa557804ace8a4c24d657f586a8e647f5001da943543d49f6d2bdec48a34017b7379305fb760436065ba7f36ce981d85c2 SHA512 fb42f462d749f824f52dd424464ecc3591e615e7e0d220a63a217797aeb3f05379fab071480946d09779dbdb9028351a596160989066589dde1be18f7d320ac8
diff --git a/dev-python/pygresql/pygresql-5.0.6.ebuild b/dev-python/pygresql/pygresql-5.0.6.ebuild
new file mode 100644
index 000000000000..1647a3dc50ca
--- /dev/null
+++ b/dev-python/pygresql/pygresql-5.0.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+POSTGRES_COMPAT=( 9.{3..6} 10 )
+PYTHON_COMPAT=( python2_7 python3_{4..7} )
+
+inherit distutils-r1 postgres
+
+MY_P="PyGreSQL-${PV}"
+
+DESCRIPTION="A Python interface for the PostgreSQL database"
+HOMEPAGE="http://www.pygresql.org/"
+SRC_URI="mirror://pypi/P/PyGreSQL/${MY_P}.tar.gz"
+
+LICENSE="POSTGRESQL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="${POSTGRES_DEP}"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+python_install_all() {
+ local DOCS=( docs/*.rst docs/community/* docs/contents/tutorial.rst )
+
+ distutils-r1_python_install_all
+}