summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-14 18:48:43 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-14 18:54:21 +0100
commit557dfc134c041eb9624d66ff028e22be922e5096 (patch)
tree65f169e29e8e573ceaf4980a8080e11e3ab847f9 /dev-python/pygsl
parentdev-python/pygments: Version Bump (diff)
downloadgentoo-557dfc134c041eb9624d66ff028e22be922e5096.tar.gz
gentoo-557dfc134c041eb9624d66ff028e22be922e5096.tar.bz2
gentoo-557dfc134c041eb9624d66ff028e22be922e5096.zip
dev-python/pygsl: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pygsl')
-rw-r--r--dev-python/pygsl/Manifest1
-rw-r--r--dev-python/pygsl/pygsl-2.1.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pygsl/Manifest b/dev-python/pygsl/Manifest
index d5d95ecb68de..4d3a32a4dee2 100644
--- a/dev-python/pygsl/Manifest
+++ b/dev-python/pygsl/Manifest
@@ -1 +1,2 @@
DIST pygsl-0.9.5.tar.gz 1674504 SHA256 05d11160ff482e1f1f5f6a047aaef2776eedc1e8e1f98533a95299584fd4752d SHA512 7364e67ff2885be2cbe5410a573071209d3917f4807797b3b8525aacd03e6ab96e157e6d12d631c384e3b66602eab7e6cb89f9ab362f520397df900e77fcc875 WHIRLPOOL 404b5f06b1088d047e7afe56311ad9ce0bdcf465ab6961f3cc9d893f575d54c2a103e4c572a60d93e4cf27ee15d4000b7dfbcd6bd33bbc4cf6638749e87f7e24
+DIST pygsl-2.1.1.tar.gz 727636 SHA256 3d17e6deb5433b331a567a45ff467f41e9059def76e6ef0f21d8e891498f946a SHA512 141232032f0221b756596bc3426160849749642ddaa3667d36b19abf3b4a22b76b5e0b0e9452898494b7f6ce0f8d17a2e392bdaba535633bbfbf1a672bf8d62e WHIRLPOOL e2c6035104ca78cb0eec5ec9bdda8dfbc01182090f1edd176c6d4565f9a71364f107eb38229c5b7758dc455337622e70b5626acbe3552e2e48219ed2f0b1f33c
diff --git a/dev-python/pygsl/pygsl-2.1.1.ebuild b/dev-python/pygsl/pygsl-2.1.1.ebuild
new file mode 100644
index 000000000000..c093fef498dc
--- /dev/null
+++ b/dev-python/pygsl/pygsl-2.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface for the GNU scientific library (gsl)"
+HOMEPAGE="http://pygsl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${P}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+DEPEND="
+ <sci-libs/gsl-2
+ dev-python/numpy[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+# Testsuite written to be run post install
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}