summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-11 11:22:13 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-11 11:59:06 +0200
commit0e8378334e32bed396fd4c6907d1e8a54f4c145d (patch)
treebd029d7d56431d0c1b7c9b7052a0a72743a46171 /dev-python/pyhamcrest/pyhamcrest-2.0.4.ebuild
parentdev-python/trove-classifiers: Bump to 2022.8.7 (diff)
downloadgentoo-0e8378334e32bed396fd4c6907d1e8a54f4c145d.tar.gz
gentoo-0e8378334e32bed396fd4c6907d1e8a54f4c145d.tar.bz2
gentoo-0e8378334e32bed396fd4c6907d1e8a54f4c145d.zip
dev-python/pyhamcrest: Bump to 2.0.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyhamcrest/pyhamcrest-2.0.4.ebuild')
-rw-r--r--dev-python/pyhamcrest/pyhamcrest-2.0.4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pyhamcrest/pyhamcrest-2.0.4.ebuild b/dev-python/pyhamcrest/pyhamcrest-2.0.4.ebuild
new file mode 100644
index 000000000000..821699b69fbc
--- /dev/null
+++ b/dev-python/pyhamcrest/pyhamcrest-2.0.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P="PyHamcrest-${PV}"
+DESCRIPTION="Hamcrest framework for matcher objects"
+HOMEPAGE="
+ https://github.com/hamcrest/PyHamcrest/
+ https://pypi.org/project/PyHamcrest/
+"
+SRC_URI="
+ https://github.com/hamcrest/PyHamcrest/archive/V${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="examples"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx doc \
+ dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}