summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl@gmail.com>2020-07-05 13:48:57 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-07-21 20:58:25 +0200
commite1d23133e46f11af2ff522f584aa1ab21a04443a (patch)
tree4b4f52236a4e5c7122f965509718e8f364af177a /dev-python/pyilmbase/files
parentmedia-libs/openexr: bump to 2.5.2 (diff)
downloadgentoo-e1d23133e46f11af2ff522f584aa1ab21a04443a.tar.gz
gentoo-e1d23133e46f11af2ff522f584aa1ab21a04443a.tar.bz2
gentoo-e1d23133e46f11af2ff522f584aa1ab21a04443a.zip
dev-python/pyilmbase: bump to 2.5.2
Remove support for python2.7 and add python-3 support. Closes: https://bugs.gentoo.org/711456 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Bernd Waibel <waebbl@gmail.com> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-python/pyilmbase/files')
-rw-r--r--dev-python/pyilmbase/files/pyilmbase-2.5.2-0001-Fix-pkgconfig-file-for-PyIlmBase-to-include-prefixes.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyilmbase/files/pyilmbase-2.5.2-0001-Fix-pkgconfig-file-for-PyIlmBase-to-include-prefixes.patch b/dev-python/pyilmbase/files/pyilmbase-2.5.2-0001-Fix-pkgconfig-file-for-PyIlmBase-to-include-prefixes.patch
new file mode 100644
index 000000000000..6e8eb30cc474
--- /dev/null
+++ b/dev-python/pyilmbase/files/pyilmbase-2.5.2-0001-Fix-pkgconfig-file-for-PyIlmBase-to-include-prefixes.patch
@@ -0,0 +1,30 @@
+From 34b8fd05781b61ce06263cdd22866a8bfc4be5b5 Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl@gmail.com>
+Date: Fri, 3 Jul 2020 22:01:18 +0200
+Subject: [PATCH] Fix pkgconfig file for PyIlmBase to include prefixes
+
+Signed-off-by: Bernd Waibel <waebbl@gmail.com>
+---
+ config/CMakeLists.txt | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/config/CMakeLists.txt b/config/CMakeLists.txt
+index 1872c89..44a9f2f 100644
+--- a/config/CMakeLists.txt
++++ b/config/CMakeLists.txt
+@@ -15,9 +15,9 @@ if(PYILMBASE_INSTALL_PKG_CONFIG)
+ # use a helper function to avoid variable pollution, but pretty simple
+ function(pyilmbase_pkg_config_help pcinfile)
+ set(prefix ${CMAKE_INSTALL_PREFIX})
+- set(exec_prefix ${CMAKE_INSTALL_BINDIR})
+- set(libdir ${CMAKE_INSTALL_LIBDIR})
+- set(includedir ${CMAKE_INSTALL_INCLUDEDIR})
++ set(exec_prefix "\${prefix}")
++ set(libdir "\${exec_prefix}/${CMAKE_INSTALL_LIBDIR}")
++ set(includedir "\${exec_prefix}/${CMAKE_INSTALL_INCLUDEDIR}")
+ set(LIB_SUFFIX_DASH ${OPENEXR_LIB_SUFFIX})
+ string(REPLACE ".in" "" pcout ${pcinfile})
+ configure_file(${pcinfile} ${CMAKE_CURRENT_BINARY_DIR}/${pcout} @ONLY)
+--
+2.27.0
+