summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl@gmail.com>2018-09-30 21:49:21 +0200
committerMichał Górny <mgorny@gentoo.org>2018-10-11 20:42:50 +0200
commit5536d29f8eda56741b434b92f3885434dba7282a (patch)
tree5c1af7b801bf293659142fda42d3d60b5c0d6ce6 /dev-python/pyilmbase/pyilmbase-2.3.0.ebuild
parentmedia-libs/openexr: bump to version 2.3.0 (diff)
downloadgentoo-5536d29f8eda56741b434b92f3885434dba7282a.tar.gz
gentoo-5536d29f8eda56741b434b92f3885434dba7282a.tar.bz2
gentoo-5536d29f8eda56741b434b92f3885434dba7282a.zip
dev-python/pyilmbase: bump to version 2.3.0
Remove multilib inherit, python isn't multilib aware Improve ebuild functions Closes: https://bugs.gentoo.org/639998 Suggested-by: Jonathan Scruggs <dracwyrm@gentoo.org> Signed-off-by: Bernd Waibel <waebbl@gmail.com> Package-Manager: Portage-2.3.49, Repoman-2.3.10 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyilmbase/pyilmbase-2.3.0.ebuild')
-rw-r--r--dev-python/pyilmbase/pyilmbase-2.3.0.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/pyilmbase/pyilmbase-2.3.0.ebuild b/dev-python/pyilmbase/pyilmbase-2.3.0.ebuild
new file mode 100644
index 000000000000..fda4c62db801
--- /dev/null
+++ b/dev-python/pyilmbase/pyilmbase-2.3.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools python-single-r1
+
+DESCRIPTION="ilmbase Python bindings"
+HOMEPAGE="http://www.openexr.com"
+SRC_URI="https://github.com/openexr/openexr/releases/download/v${PV}/${P}.tar.gz"
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+numpy"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEP}
+ >=dev-libs/boost-1.62.0-r1[python(+),${PYTHON_USEDEP}]
+ ~media-libs/ilmbase-${PV}:=
+ numpy? ( >=dev-python/numpy-1.10.4 )"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEP}
+ >=virtual/pkgconfig-0-r1"
+
+PATCHES=(
+ "${FILESDIR}/${P}-link-pyimath.patch"
+ "${FILESDIR}/${P}-fix-build-system.patch"
+)
+
+DOCS=( README.md )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-boost-include-dir="${EPREFIX}/usr/include/boost"
+ --with-boost-lib-dir="${EPREFIX}/usr/$(get_libdir)"
+ --with-boost-python-libname="boost_python-${EPYTHON:6}"
+ $(use_with numpy)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ # Fails to install with multiple jobs
+ emake DESTDIR="${D}" -j1 install
+
+ einstalldocs
+
+ # package provides pkg-config files
+ find "${D}" -name '*.la' -delete || die
+}