summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2016-11-21 14:17:47 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2016-11-21 14:21:28 +0100
commitcef306ecd043bc397de9f36aaafb104e706e90ab (patch)
tree78fdc00fe06cd82550ae12f707b38dd3820b7396 /dev-python/pyinsane/pyinsane-2.0.6.ebuild
parentx11-themes/qtcurve: Use kde5.eclass (diff)
downloadgentoo-cef306ecd043bc397de9f36aaafb104e706e90ab.tar.gz
gentoo-cef306ecd043bc397de9f36aaafb104e706e90ab.tar.bz2
gentoo-cef306ecd043bc397de9f36aaafb104e706e90ab.zip
dev-python/pyinsane: version bump to 2.0.6
Mostly keeping up with upstream version, most changes are windows-only Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-python/pyinsane/pyinsane-2.0.6.ebuild')
-rw-r--r--dev-python/pyinsane/pyinsane-2.0.6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pyinsane/pyinsane-2.0.6.ebuild b/dev-python/pyinsane/pyinsane-2.0.6.ebuild
new file mode 100644
index 000000000000..3bc931d126de
--- /dev/null
+++ b/dev-python/pyinsane/pyinsane-2.0.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the Sane API and abstration layer"
+HOMEPAGE="https://github.com/jflesch/pyinsane"
+SRC_URI="https://github.com/jflesch/pyinsane/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="media-gfx/sane-backends
+ dev-python/pillow[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+RESTRICT="test" # Tests require at least one scanner with a flatbed and an ADF
+
+python_prepare_all() {
+ sed -e "/'nose>=1.0'/d" -i setup.py || die
+ distutils-r1_python_prepare_all
+}