summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2017-01-02 12:09:44 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2017-01-02 12:18:21 +0100
commit22bcf31294f0eeabc4c411d744e243b48c8952c9 (patch)
tree10cc65434b9805ee0635e48c08fbb8f4eca6e719 /dev-python/pyinsane/pyinsane-2.0.9.ebuild
parentdev-python/pyinsane: drop old (diff)
downloadgentoo-22bcf31294f0eeabc4c411d744e243b48c8952c9.tar.gz
gentoo-22bcf31294f0eeabc4c411d744e243b48c8952c9.tar.bz2
gentoo-22bcf31294f0eeabc4c411d744e243b48c8952c9.zip
dev-python/pyinsane: 2.0.9 bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/pyinsane/pyinsane-2.0.9.ebuild')
-rw-r--r--dev-python/pyinsane/pyinsane-2.0.9.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pyinsane/pyinsane-2.0.9.ebuild b/dev-python/pyinsane/pyinsane-2.0.9.ebuild
new file mode 100644
index 000000000000..d311512f9065
--- /dev/null
+++ b/dev-python/pyinsane/pyinsane-2.0.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the Sane API and abstration layer"
+HOMEPAGE="https://github.com/jflesch/pyinsane"
+SRC_URI="https://github.com/jflesch/pyinsane/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="media-gfx/sane-backends
+ dev-python/pillow[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+RESTRICT="test" # Tests require at least one scanner with a flatbed and an ADF
+
+python_prepare_all() {
+ sed -e "/'nose>=1.0'/d" -i setup.py || die
+ distutils-r1_python_prepare_all
+}