summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-27 09:51:34 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-27 10:20:21 +0100
commit17bc6771b42418227aacdfe31e2bbf9c5bf46af7 (patch)
treefcfb9ffb7c8da625d978651396664f0105a11a14 /dev-python/pykka
parentdev-python/pytest-xprocess: Bump to 0.17.0 (diff)
downloadgentoo-17bc6771b42418227aacdfe31e2bbf9c5bf46af7.tar.gz
gentoo-17bc6771b42418227aacdfe31e2bbf9c5bf46af7.tar.bz2
gentoo-17bc6771b42418227aacdfe31e2bbf9c5bf46af7.zip
dev-python/pykka: Bump to 2.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pykka')
-rw-r--r--dev-python/pykka/Manifest1
-rw-r--r--dev-python/pykka/pykka-2.0.3.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pykka/Manifest b/dev-python/pykka/Manifest
index 35ce1fa09aab..aa6fce924df3 100644
--- a/dev-python/pykka/Manifest
+++ b/dev-python/pykka/Manifest
@@ -1 +1,2 @@
DIST Pykka-2.0.2.tar.gz 51858 BLAKE2B 62132a3ded257d44d9504258418abc73ec9cc09353ab8e1948c9910fc11f67f770510b2dc7cf122db9af9ff62091757b648dce69cbdab0ffc17567169749d0d2 SHA512 98b2e6122dc5158da489265cf7cf9e358bfa432d0a0eaab9f50a07c0050083afb19aad494e4cd27347c376947eafb7d9796909c18e3648ef1bf0685bd6384e5b
+DIST Pykka-2.0.3.tar.gz 55749 BLAKE2B 5da98dcc786c2bb7728485e16090b8dad7a96858aa86f024564286bb03d3faa93673ed3db87882e3dc6555a5b64c9c62433ab782ceb94e89965fa870bbb78d2f SHA512 0f4d6d9e0c92a7e7cafb340f343afa1e78bcefdd0454341d3f457fa202acdd3de979881689cb3cd5f2cbd3a08f80177f6470db4fb895b20d9c1b4d0b9ef627ee
diff --git a/dev-python/pykka/pykka-2.0.3.ebuild b/dev-python/pykka/pykka-2.0.3.ebuild
new file mode 100644
index 000000000000..28d617977753
--- /dev/null
+++ b/dev-python/pykka/pykka-2.0.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+MY_P=${P^}
+DESCRIPTION="A Python implementation of the actor model"
+HOMEPAGE="https://www.pykka.org/en/latest/ https://github.com/jodal/pykka"
+SRC_URI="mirror://pypi/${MY_P::1}/${PN^}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest