summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-22 00:47:58 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-22 00:51:07 +0200
commit34ce7e93f4e7ab8193e6da387b707195667cf52f (patch)
treea7e9ed44a7c5b1819f694df60e9dd74ad10b8639 /dev-python/pylama
parentdev-python/pygresql: Remove old (diff)
downloadgentoo-34ce7e93f4e7ab8193e6da387b707195667cf52f.tar.gz
gentoo-34ce7e93f4e7ab8193e6da387b707195667cf52f.tar.bz2
gentoo-34ce7e93f4e7ab8193e6da387b707195667cf52f.zip
dev-python/pylama: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pylama')
-rw-r--r--dev-python/pylama/pylama-7.7.1.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/pylama/pylama-7.7.1.ebuild b/dev-python/pylama/pylama-7.7.1.ebuild
deleted file mode 100644
index 76978aea548b..000000000000
--- a/dev-python/pylama/pylama-7.7.1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PYTHON_COMPAT=( python3_{6,7} )
-DISTUTILS_USE_SETUPTOOLS="rdepend"
-
-inherit distutils-r1
-
-DESCRIPTION="Code audit tool for python"
-HOMEPAGE="https://github.com/klen/pylama"
-SRC_URI="https://github.com/klen/pylama/archive/${PV}.tar.gz -> ${P}.tar.gz"
-# pypi tarball excludes unit tests
-#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="
- >=dev-python/mccabe-0.5.2[${PYTHON_USEDEP}]
- dev-python/pycodestyle[${PYTHON_USEDEP}]
- dev-python/pydocstyle[${PYTHON_USEDEP}]
- dev-python/pyflakes[${PYTHON_USEDEP}]
-"
-DEPEND="
- ${RDEPEND}
- test? (
- dev-python/eradicate[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/radon[${PYTHON_USEDEP}]
- )
-"
-
-python_prepare_all() {
- sed -e "s|exclude=\['plugins'\]|exclude=['plugins', 'tests']|" -i setup.py || die
- sed -e 's|^\(def\) \(test_ignore_select\)|\1 _\2|' -i tests/test_config.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- py.test -v tests || die "Tests failed with ${EPYTHON}"
-}