summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <holgersson@posteo.de>2020-03-25 16:54:13 +0100
committerZac Medico <zmedico@gentoo.org>2020-04-03 23:18:37 -0700
commit5a60ee36af706f59fb398fb8d9dc77c0294d8d0a (patch)
tree5d4b8125b5a101ef04eda1b877344f112137fc4f /dev-python/pylama
parentmedia-sound/ardour: remove nag text (diff)
downloadgentoo-5a60ee36af706f59fb398fb8d9dc77c0294d8d0a.tar.gz
gentoo-5a60ee36af706f59fb398fb8d9dc77c0294d8d0a.tar.bz2
gentoo-5a60ee36af706f59fb398fb8d9dc77c0294d8d0a.zip
dev-python/pylama: Bump to 7.7.1
Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Nils Freydank <holgersson@posteo.de> Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-python/pylama')
-rw-r--r--dev-python/pylama/Manifest1
-rw-r--r--dev-python/pylama/pylama-7.7.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pylama/Manifest b/dev-python/pylama/Manifest
index 40d22231ecaa..3725fe8f84e2 100644
--- a/dev-python/pylama/Manifest
+++ b/dev-python/pylama/Manifest
@@ -1 +1,2 @@
DIST pylama-7.6.5.tar.gz 33680 BLAKE2B a80d976a6a5e7903f3e4aa6b36777b6a938d52980232d1858bbd602d277bce4b058f8ad404e6dc6692e6950ff36d8e698ff0e3afa44c06334a6bdbe728f15cdd SHA512 0ce2438622cdb3e85fb70d4246cdcc29940181dce82a1a641f6b7900a13f09cba0f871038992019a2e1ccc720dcd6dd5e21786bd8a2df40479a34c500a80fab4
+DIST pylama-7.7.1.tar.gz 34740 BLAKE2B a4bd5aed40c2c4e7bdb9f9968030f0954f0309cff80567b2252ee9576fdb4598714286bda63c22676789d4919662430ef2729089faa70b5cb590784eb47ef1f0 SHA512 298fabffcdf38e3e868e3965de87a0e761bc9dfcfe33320b53057c4e05598bcc22045481ec16ccb8df27f49ea41d6fef82b69fe7327905f93ce74d9350682cf0
diff --git a/dev-python/pylama/pylama-7.7.1.ebuild b/dev-python/pylama/pylama-7.7.1.ebuild
new file mode 100644
index 000000000000..76978aea548b
--- /dev/null
+++ b/dev-python/pylama/pylama-7.7.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6,7} )
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="Code audit tool for python"
+HOMEPAGE="https://github.com/klen/pylama"
+SRC_URI="https://github.com/klen/pylama/archive/${PV}.tar.gz -> ${P}.tar.gz"
+# pypi tarball excludes unit tests
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/mccabe-0.5.2[${PYTHON_USEDEP}]
+ dev-python/pycodestyle[${PYTHON_USEDEP}]
+ dev-python/pydocstyle[${PYTHON_USEDEP}]
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/eradicate[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/radon[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ sed -e "s|exclude=\['plugins'\]|exclude=['plugins', 'tests']|" -i setup.py || die
+ sed -e 's|^\(def\) \(test_ignore_select\)|\1 _\2|' -i tests/test_config.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test -v tests || die "Tests failed with ${EPYTHON}"
+}