summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-07 07:26:30 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-07 08:54:01 +0200
commit862e84c96b322d29e3abad1423fb15396acd5e2d (patch)
tree82d5881e8f8b07ebdda0e714ef465a4bca2cb343 /dev-python/pylint
parentdev-python/dulwich: Bump to 0.20.43 (diff)
downloadgentoo-862e84c96b322d29e3abad1423fb15396acd5e2d.tar.gz
gentoo-862e84c96b322d29e3abad1423fb15396acd5e2d.tar.bz2
gentoo-862e84c96b322d29e3abad1423fb15396acd5e2d.zip
dev-python/pylint: Bump to 2.14.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/pylint-2.14.1.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index e7ecffe0269c..75d789bb1bb0 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1 +1,2 @@
DIST pylint-2.13.9.gh.tar.gz 1123216 BLAKE2B f80e88f565595b16bba650a009bfdd6d55efa65227898d145d4867c116c89c7ab5244c509382f0e9023404b4e46accb742334450ca7342394fb4d0abaccb8d03 SHA512 dcea90b1b1494d928f0b12dd2b50ee1d97a74efce18e0ef54ea02b52209a574977971e12db8f476edcf1bd646ca41c6a77bcf9a425c01af71bd29e54fd6c20b9
+DIST pylint-2.14.1.gh.tar.gz 1270750 BLAKE2B 120cc78c3d76ccb10f88c94b5528f1ed42730b49ac7daea4c1e65cd82fa2aea2c7d77a3a26dcb84201c69afeceb538cddf1ba740af308b586624ee3d40656d49 SHA512 4be985bb78e4b2bd65a195b95fdeb2a95c59c82db2446c9c365b11f0ba57e2a3234a41865071272cb054647a15e7e1a8b48d034ca656a3a44ca509648f258c13
diff --git a/dev-python/pylint/pylint-2.14.1.ebuild b/dev-python/pylint/pylint-2.14.1.ebuild
new file mode 100644
index 000000000000..42b2494ce503
--- /dev/null
+++ b/dev-python/pylint/pylint-2.14.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="
+ https://pypi.org/project/pylint/
+ https://github.com/PyCQA/pylint/
+"
+SRC_URI="
+ https://github.com/pycqa/pylint/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="examples"
+
+# Make sure to check https://github.com/PyCQA/pylint/blob/main/setup.cfg#L43 on bumps
+# Adjust dep bounds!
+RDEPEND="
+ <dev-python/astroid-2.12[${PYTHON_USEDEP}]
+ >=dev-python/astroid-2.11.5[${PYTHON_USEDEP}]
+ >=dev-python/dill-0.2[${PYTHON_USEDEP}]
+ >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
+ <dev-python/isort-6[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.8[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.10.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+BDEPEND="
+ test? (
+ >=dev-python/GitPython-3[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ rm -rf pylint || die
+
+ local EPYTEST_DESELECT=(
+ # No need to run the benchmarks
+ tests/benchmark/test_baseline_benchmarks.py
+
+ # TODO
+ 'tests/test_functional.py::test_functional[forgotten_debug_statement_py37]'
+ 'tests/test_functional.py::test_functional[dataclass_with_field]'
+ 'tests/test_functional.py::test_functional[no_name_in_module]'
+ tests/checkers/unittest_typecheck.py::TestTypeChecker::test_nomember_on_c_extension_error_msg
+ tests/checkers/unittest_typecheck.py::TestTypeChecker::test_nomember_on_c_extension_info_msg
+ tests/config/pylint_config/test_run_pylint_config.py::test_invocation_of_pylint_config
+ )
+ # Specify the test directory explicitly to avoid import file mismatches
+ epytest
+}
+
+python_install_all() {
+ if use examples ; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+}