summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pylons
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pylons')
-rw-r--r--dev-python/pylons/Manifest1
-rw-r--r--dev-python/pylons/metadata.xml12
-rw-r--r--dev-python/pylons/pylons-1.0.1-r1.ebuild54
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/pylons/Manifest b/dev-python/pylons/Manifest
new file mode 100644
index 000000000000..681f5d2b5b26
--- /dev/null
+++ b/dev-python/pylons/Manifest
@@ -0,0 +1 @@
+DIST Pylons-1.0.1.tar.gz 2299257 SHA256 7c22579516d92e6fcab3f9555b33fe7a259cc2e16d2fe414816c0138c91e8c0d SHA512 1b34541c912c914636fc7b0d358439a6705e5161a306a4bfa6a08cbc1ee4741cb3882afc9cae9a22d208f89f9648a4b7559304842339c8d6d75472f058a91ceb WHIRLPOOL 58019b223a0fc52f5cf7582a03ae7f5b25c29b88d3faff42c03ed5602f3fb2bc4bc9a4cce48d761109c2c7a4edc0b05ffcb100bf1bab70cf572f93c6da38d2c8
diff --git a/dev-python/pylons/metadata.xml b/dev-python/pylons/metadata.xml
new file mode 100644
index 000000000000..10c66b0d7fe6
--- /dev/null
+++ b/dev-python/pylons/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <use>
+ <flag name="genshi">Add optional genshi support</flag>
+ <flag name="jinja">Add optional jinja support</flag>
+ </use>
+ <upstream>
+ <remote-id type="pypi">Pylons</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pylons/pylons-1.0.1-r1.ebuild b/dev-python/pylons/pylons-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..630e9e1c4e09
--- /dev/null
+++ b/dev-python/pylons/pylons-1.0.1-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="Pylons"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Pylons Web Framework"
+HOMEPAGE="http://pylonshq.com/ http://pypi.python.org/pypi/Pylons"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="genshi jinja test"
+
+RDEPEND=">=dev-python/beaker-1.3[${PYTHON_USEDEP}]
+ >=dev-python/decorator-2.3.2[${PYTHON_USEDEP}]
+ >=dev-python/formencode-1.2.1[${PYTHON_USEDEP}]
+ >=dev-python/mako-0.2.4[${PYTHON_USEDEP}]
+ >=dev-python/nose-0.10.4[${PYTHON_USEDEP}]
+ >=dev-python/paste-1.7.2[${PYTHON_USEDEP}]
+ >=dev-python/pastedeploy-1.3.3[${PYTHON_USEDEP}]
+ >=dev-python/pastescript-1.7.3[${PYTHON_USEDEP}]
+ >=dev-python/repoze-lru-0.3[${PYTHON_USEDEP}]
+ >=dev-python/routes-1.12[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-2.0.8[${PYTHON_USEDEP}]
+ >=dev-python/tempita-0.2[${PYTHON_USEDEP}]
+ >=dev-python/weberror-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/webhelpers-0.6.4[${PYTHON_USEDEP}]
+ >=dev-python/webob-0.9.6.1[${PYTHON_USEDEP}]
+ >=dev-python/webtest-1.1[${PYTHON_USEDEP}]
+ genshi? ( >=dev-python/genshi-0.4.4[${PYTHON_USEDEP}] )
+ jinja? ( >=dev-python/jinja-2[${PYTHON_USEDEP}] )"
+# Dependency on >=dev-python/coverage-2.85 and dev-python/genshi is not with Jython.
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/coverage-2.85[${PYTHON_USEDEP}]
+ dev-python/genshi[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.2.1[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}