summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWim Muskee <wimmuskee@gmail.com>2019-12-08 16:21:51 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-08 16:21:51 +0100
commit269ea5409c18ea6cfabd07fa2a3b2054c4ba8af1 (patch)
treea60a86696fee23e1ce7bc4368b137195f06f0156 /dev-python/pymad/pymad-0.10.ebuild
parentmedia-video/yle-dl: remove old (diff)
downloadgentoo-269ea5409c18ea6cfabd07fa2a3b2054c4ba8af1.tar.gz
gentoo-269ea5409c18ea6cfabd07fa2a3b2054c4ba8af1.tar.bz2
gentoo-269ea5409c18ea6cfabd07fa2a3b2054c4ba8af1.zip
dev-python/pymad: version bump to 0.10, add py3 support, update metadata
Closes: https://bugs.gentoo.org/702120 Closes: https://github.com/gentoo/gentoo/pull/13915 Signed-off-by: Wim Muskee <wimmuskee@gmail.com> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/pymad/pymad-0.10.ebuild')
-rw-r--r--dev-python/pymad/pymad-0.10.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/pymad/pymad-0.10.ebuild b/dev-python/pymad/pymad-0.10.ebuild
new file mode 100644
index 000000000000..f05e37f069e7
--- /dev/null
+++ b/dev-python/pymad/pymad-0.10.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for libmad MP3 decoding in python"
+HOMEPAGE="https://github.com/jaqx0r/pymad"
+SRC_URI="https://github.com/jaqx0r/${PN}/archive/version/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="media-libs/libmad"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-version-${PV}"