summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-17 13:28:43 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-17 14:19:26 +0200
commit71a22e500634ea1531a3cb0c59dea725fc294820 (patch)
tree41ea2446e9b2b23ec4e2ef52f2e16fad0285f281 /dev-python/pymdown-lexers
parentdev-python/pymdown-extensions: enable py3.11 (diff)
downloadgentoo-71a22e500634ea1531a3cb0c59dea725fc294820.tar.gz
gentoo-71a22e500634ea1531a3cb0c59dea725fc294820.tar.bz2
gentoo-71a22e500634ea1531a3cb0c59dea725fc294820.zip
dev-python/pymdown-lexers: add 0_pre20210902
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/pymdown-lexers')
-rw-r--r--dev-python/pymdown-lexers/Manifest1
-rw-r--r--dev-python/pymdown-lexers/pymdown-lexers-0_pre20210902.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pymdown-lexers/Manifest b/dev-python/pymdown-lexers/Manifest
index 66678bbe66f2..a7574252339a 100644
--- a/dev-python/pymdown-lexers/Manifest
+++ b/dev-python/pymdown-lexers/Manifest
@@ -1 +1,2 @@
DIST pymdown-lexers-0_pre20210308.tar.gz 2962 BLAKE2B 6504974327727cf49c9a6584cf06dee1505c8e0266241b584f84c3a99f6e8344e3dafda2bcdd3773d06e634a6d6aecd1279b40f3126ffdddb77f3218a1a18034 SHA512 08beadf0ee24bc33b6eb231d297bdbb084954fba4a22fb0beed3bb08c2e188bf984465a61138affbcdbf843831bbd7d2f2d26c798c60048145a42d365ae81dd3
+DIST pymdown-lexers-0_pre20210902.tar.gz 2998 BLAKE2B cd9793c247abd7ac2ff2a8104f1b43ef034a8da14fa27c86c59794b7f53c22e75820a0033673e44824f98b50a4e9af446538428252a4064223e5ad35bdeac23a SHA512 c411f935ca0fedbdd0547c2c78d2292d8a07469f90b401d29fc1c2cc1eb899fde865a5eefa253eade03dc139af6188e0b655b8924465238ce9a53cd636eb5b53
diff --git a/dev-python/pymdown-lexers/pymdown-lexers-0_pre20210902.ebuild b/dev-python/pymdown-lexers/pymdown-lexers-0_pre20210902.ebuild
new file mode 100644
index 000000000000..43e9cae5bf38
--- /dev/null
+++ b/dev-python/pymdown-lexers/pymdown-lexers-0_pre20210902.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+COMMIT="4cd030ad37bedff37345b37c1f1cd118530429ed"
+
+DESCRIPTION="Additional lexers for use in Pygments"
+HOMEPAGE="https://github.com/facelessuser/pymdown-lexers"
+SRC_URI="https://github.com/facelessuser/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pygments-2.0.1[${PYTHON_USEDEP}]
+"