summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-02-05 17:47:07 -0800
committerPatrick McLean <chutzpah@gentoo.org>2020-02-05 17:48:06 -0800
commitb1c38c971672390a31ff0d3ac89a54d9b0ec8fcb (patch)
tree81bd675b6d0e729c368552e6d0ccc63021628dd1 /dev-python/pymdstat
parentdev-games/simgear: Build against sci-libs/gdal:3, bug 688130 (diff)
downloadgentoo-b1c38c971672390a31ff0d3ac89a54d9b0ec8fcb.tar.gz
gentoo-b1c38c971672390a31ff0d3ac89a54d9b0ec8fcb.tar.bz2
gentoo-b1c38c971672390a31ff0d3ac89a54d9b0ec8fcb.zip
dev-python/pymdstat-0.4.2-r1: revbump, enable tests, add py38, EAPI=7
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/pymdstat')
-rw-r--r--dev-python/pymdstat/Manifest2
-rw-r--r--dev-python/pymdstat/pymdstat-0.4.2-r1.ebuild29
-rw-r--r--dev-python/pymdstat/pymdstat-0.4.2.ebuild29
3 files changed, 30 insertions, 30 deletions
diff --git a/dev-python/pymdstat/Manifest b/dev-python/pymdstat/Manifest
index 76d0cf2e86f4..fecc9308e5fd 100644
--- a/dev-python/pymdstat/Manifest
+++ b/dev-python/pymdstat/Manifest
@@ -1 +1 @@
-DIST pymdstat-0.4.2.tar.gz 5010 BLAKE2B 4fe196916809513b063144ca4097676e2c826f38bccfdcb387aabd95d6b5d471eceec1a29fc5ffb41e7019e1570e2d805bbfa10f22ec7ececcb30afd7fc1a4ed SHA512 2e3c07d59151069962e1ba601b3751b331e233fdc6bbdeb0cada69ce36a731c12bcc6447218cc0c1ae4dd63d39d2be2bc3677aba739797cc534c5e38d1c72458
+DIST pymdstat-0.4.2-r1.tar.gz 14798 BLAKE2B 179c88a8999b4908586a3bc1698de9df25e94203b723b2981f9ac6e1b2ef47845c9e625c1daa40990dff7e90aece34fc471c3c5a0278a85c4c526d37574e5fed SHA512 7c9815b365fdb37ffe37c65d280a3bc4370f09fb8dad18ff9c68f61b8cc906e6b8d8e0fe0dd1570e68349f535f23cfb8afd52ba805d78e795d5c6f9730f7f2d0
diff --git a/dev-python/pymdstat/pymdstat-0.4.2-r1.ebuild b/dev-python/pymdstat/pymdstat-0.4.2-r1.ebuild
new file mode 100644
index 000000000000..1ba2d042f2be
--- /dev/null
+++ b/dev-python/pymdstat/pymdstat-0.4.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,8} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Python library to parse Linux /proc/mdstat"
+HOMEPAGE="https://github.com/nicolargo/pymdstat
+ https://pypi.org/project/pymdstat/"
+
+# drop the ${PVR} if there is a version bump
+SRC_URI="https://github.com/nicolargo/${PN}/archive/v${PV}.tar.gz -> ${PN}-${PVR}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DOCS=( 'AUTHORS' 'NEWS' 'README.rst' )
+
+python_prepare_all() {
+ sed -e '/data_files/ d' -i setup.py || die "sed failed"
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${EPYTHON}" unitest.py -v || die "testing failed with ${EPYTHON}"
+}
diff --git a/dev-python/pymdstat/pymdstat-0.4.2.ebuild b/dev-python/pymdstat/pymdstat-0.4.2.ebuild
deleted file mode 100644
index aea52cd31c37..000000000000
--- a/dev-python/pymdstat/pymdstat-0.4.2.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library to parse Linux /proc/mdstat"
-HOMEPAGE="https://github.com/nicolargo/pymdstat
- https://pypi.org/project/pymdstat/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-# Not included
-RESTRICT=test
-
-python_test() {
- ${PYTHON} unitest.py || die
-}