summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-22 13:05:31 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-22 13:09:19 +0200
commit0ecf16fd3d01d84afa35412ff9a2aad8b174d422 (patch)
treeec06dd4a134a8f3ba6dda74cb76ba02f91b304a3 /dev-python/pymongo/pymongo-2.6.3.ebuild
parentdev-python/inotifyx: Fix test function (diff)
downloadgentoo-0ecf16fd3d01d84afa35412ff9a2aad8b174d422.tar.gz
gentoo-0ecf16fd3d01d84afa35412ff9a2aad8b174d422.tar.bz2
gentoo-0ecf16fd3d01d84afa35412ff9a2aad8b174d422.zip
dev-python/pymongo: Drop deprecated usage of DISTUTILS_NO_PARALLEL_BUILD and QA fixes
Add missing die ADd missing PYTHON_USEDEP Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pymongo/pymongo-2.6.3.ebuild')
-rw-r--r--dev-python/pymongo/pymongo-2.6.3.ebuild15
1 files changed, 4 insertions, 11 deletions
diff --git a/dev-python/pymongo/pymongo-2.6.3.ebuild b/dev-python/pymongo/pymongo-2.6.3.ebuild
index 7eb0fbf49103..9050b51bf4b0 100644
--- a/dev-python/pymongo/pymongo-2.6.3.ebuild
+++ b/dev-python/pymongo/pymongo-2.6.3.ebuild
@@ -22,7 +22,7 @@ DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( dev-python/nose[${PYTHON_USEDEP}] )
- kerberos? ( dev-python/pykerberos )"
+ kerberos? ( dev-python/pykerberos[${PYTHON_USEDEP}] )"
DISTUTILS_IN_SOURCE_BUILD=1
reqcheck() {
@@ -49,20 +49,13 @@ python_compile_all() {
fi
}
-src_test() {
+python_test() {
# Yes, we need TCP/IP for that...
local DB_IP=127.0.0.1
local DB_PORT=27000
export DB_IP DB_PORT
- # 1.5G of disk space per run.
- local DISTUTILS_NO_PARALLEL_BUILD=1
-
- distutils-r1_src_test
-}
-
-python_test() {
local dbpath=${TMPDIR}/mongo.db
local logpath=${TMPDIR}/mongod.log
@@ -108,11 +101,11 @@ python_test() {
fi
DB_PORT2=$(( DB_PORT + 1 )) DB_PORT3=$(( DB_PORT + 2 )) esetup.py test || failed=1
- mongod --dbpath "${dbpath}" --shutdown
+ mongod --dbpath "${dbpath}" --shutdown || die
[[ ${failed} ]] && die "Tests fail with ${EPYTHON}"
- rm -rf "${dbpath}"
+ rm -rf "${dbpath}" || die
}
python_install() {