summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-01 04:34:33 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-01 04:36:07 +0100
commitef2811e183abea7ce20a50ef65e0bf9bcf8d1a46 (patch)
treeb792be1803be33d38646ceef5ef27c921c134d5a /dev-python/pynacl/pynacl-1.5.0-r1.ebuild
parentdev-python/msgpack: Remove stale six dependency (diff)
downloadgentoo-ef2811e183abea7ce20a50ef65e0bf9bcf8d1a46.tar.gz
gentoo-ef2811e183abea7ce20a50ef65e0bf9bcf8d1a46.tar.bz2
gentoo-ef2811e183abea7ce20a50ef65e0bf9bcf8d1a46.zip
dev-python/pynacl: Remove stale dev-python/six dependency
Closes: https://bugs.gentoo.org/878917 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pynacl/pynacl-1.5.0-r1.ebuild')
-rw-r--r--dev-python/pynacl/pynacl-1.5.0-r1.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/pynacl/pynacl-1.5.0-r1.ebuild b/dev-python/pynacl/pynacl-1.5.0-r1.ebuild
deleted file mode 100644
index b108506dab01..000000000000
--- a/dev-python/pynacl/pynacl-1.5.0-r1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python binding to the Networking and Cryptography (NaCl) library"
-HOMEPAGE="
- https://github.com/pyca/pynacl/
- https://pypi.org/project/PyNaCl/
-"
-SRC_URI="
- https://github.com/pyca/${PN}/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/cffi-1.4.1[${PYTHON_USEDEP}]
- dev-libs/libsodium:0/23
-"
-BDEPEND="${RDEPEND}
- test? (
- >=dev-python/hypothesis-3.27.0[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_compile() {
- # For not using the bundled libsodium
- local -x SODIUM_INSTALL=system
- distutils-r1_src_compile
-}