summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-03-26 10:56:47 -0700
committerPatrick McLean <chutzpah@gentoo.org>2019-03-26 13:15:41 -0700
commitb459cce299bf53a22a9e63325f198cfcf4174636 (patch)
tree091093c314adfd367a2b36efddb776c8a142b8d3 /dev-python/pynacl
parentRevert "app-doc/eclass-manpages: remove unused file" (diff)
downloadgentoo-b459cce299bf53a22a9e63325f198cfcf4174636.tar.gz
gentoo-b459cce299bf53a22a9e63325f198cfcf4174636.tar.bz2
gentoo-b459cce299bf53a22a9e63325f198cfcf4174636.zip
dev-python/pynacl: Version bump to 1.3.0
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/pynacl')
-rw-r--r--dev-python/pynacl/Manifest1
-rw-r--r--dev-python/pynacl/pynacl-1.3.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pynacl/Manifest b/dev-python/pynacl/Manifest
index 4e6aa1c31395..7755fc14a6de 100644
--- a/dev-python/pynacl/Manifest
+++ b/dev-python/pynacl/Manifest
@@ -1,3 +1,4 @@
DIST pynacl-1.1.2.tar.gz 3149804 BLAKE2B 2ddf6728bfc5a8d5984ecf3fe054a7f36acf15b64d9ba42df93bb21940b9646997d59500825cdf04deeba9afbf4d227a016ad631211d18cba2ab1a38bdd89541 SHA512 ce9c720699fc3b808bb569ad9916f5f5ea97fbc49643117b014374ffaf77ce7972a530e9c4cfaca14dcffc8d676b5bce2facf6da99bf2fda4e319b772075e52e
DIST pynacl-1.2.0.tar.gz 3301645 BLAKE2B 7309409d7913bf1dee690a6fba5dd490de7a5cd41119e68115452a8c51317005d10eebfa7017f0a182f07bd20ef36f7b395c9461e3e7929cb1102b24afcb937b SHA512 ffc3b91766aad9d0d21c88c198ebb7520d204e58ffbcac815a382af7eaf9b489f85ae6c2fc4cfe4dd5e04576062bfe248bdcc08fb42bf184a73e41f4352c7bd1
DIST pynacl-1.2.1.tar.gz 3302051 BLAKE2B 96278368427c2b5f1d9508a5d9a36853a9c50390ee3ada20d6344e4f7f67fb3f1285c45794b863f129b48feff8a5a3d4a20796f69e832cec2aef26f27961d925 SHA512 15a3a84fed4d002072c185ca346c708ed0fb397ca3a8d0144caced635cc2e00e19603767cf9fcedc571cb4bf32c546141094ce44536dd117c3775efb2fc589b9
+DIST pynacl-1.3.0.tar.gz 3405949 BLAKE2B e6a6444eed2cbf134ee6060ef382981f6bfb8396fbae30dc1e16f7702a559b7ea56889d9889adfea09ac6644732fafb98e07da99e3a41392303b6a45f0b494b1 SHA512 815c31a2069cbee1091d7e0ebf0b5572875c4a537311af561b5bce0b9d8051028e367a516b46481453d9780e60e9e7e2a4640d320164059c3974b0319d1cf96d
diff --git a/dev-python/pynacl/pynacl-1.3.0.ebuild b/dev-python/pynacl/pynacl-1.3.0.ebuild
new file mode 100644
index 000000000000..c0afe300d433
--- /dev/null
+++ b/dev-python/pynacl/pynacl-1.3.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7})
+
+inherit distutils-r1
+
+DESCRIPTION="Python binding to the Networking and Cryptography (NaCl) library"
+HOMEPAGE="https://github.com/pyca/pynacl/ https://pypi.org/project/PyNaCl/"
+SRC_URI="https://github.com/pyca/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd"
+IUSE="test"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/cffi-1.4.1[${PYTHON_USEDEP}]
+ dev-libs/libsodium:0/23
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/hypothesis-3.27.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.2.1[${PYTHON_USEDEP}] )
+"
+
+src_prepare() {
+ # For not using the bundled libsodium
+ export SODIUM_INSTALL=system
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test -v || die "Tests failed under ${EPYTHON}"
+}