summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-03-27 19:47:22 +0200
committerMichał Górny <mgorny@gentoo.org>2017-03-27 20:16:39 +0200
commit288b2b760300c1b4c302fba91c532c46e585a0df (patch)
treebb31e1889a3a0815ad539555da6dc54baec52d0e /dev-python/pynotifier/pynotifier-0.7.0-r3.ebuild
parentnet-libs/nghttp2: Bump to version 1.21.0 (diff)
downloadgentoo-288b2b760300c1b4c302fba91c532c46e585a0df.tar.gz
gentoo-288b2b760300c1b4c302fba91c532c46e585a0df.tar.bz2
gentoo-288b2b760300c1b4c302fba91c532c46e585a0df.zip
dev-python/pynotifier: Support combined dev-python/twisted
Diffstat (limited to 'dev-python/pynotifier/pynotifier-0.7.0-r3.ebuild')
-rw-r--r--dev-python/pynotifier/pynotifier-0.7.0-r3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pynotifier/pynotifier-0.7.0-r3.ebuild b/dev-python/pynotifier/pynotifier-0.7.0-r3.ebuild
new file mode 100644
index 000000000000..54dbdb9aaf2a
--- /dev/null
+++ b/dev-python/pynotifier/pynotifier-0.7.0-r3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="pyNotifier provides an implementation of a notifier/event scheduler"
+HOMEPAGE="http://www.bitkipper.net/"
+SRC_URI="http://www.bitkipper.net/bytes/debian/dists/unstable/source/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="qt4 gtk"
+
+DEPEND=""
+RDEPEND="
+ || (
+ dev-python/twisted[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+ )
+ gtk? ( dev-python/pygobject:2[${PYTHON_USEDEP}] )
+ qt4? ( dev-python/PyQt4[X,${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ use gtk || rm notifier/nf_gtk.py
+ use qt4 || rm notifier/nf_qt.py
+ distutils-r1_python_prepare_all
+}