summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-27 06:19:05 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-27 06:40:43 +0200
commitd7e35bc59596a8f94babf3b254385bed3840eb8a (patch)
tree773c5296b4aca815d6064c30b786b96b43abe9ed /dev-python/pyocr
parentdev-python/cachelib: Bump to 0.9.0 (diff)
downloadgentoo-d7e35bc59596a8f94babf3b254385bed3840eb8a.tar.gz
gentoo-d7e35bc59596a8f94babf3b254385bed3840eb8a.tar.bz2
gentoo-d7e35bc59596a8f94babf3b254385bed3840eb8a.zip
dev-python/pyocr: Bump to 0.8.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyocr')
-rw-r--r--dev-python/pyocr/Manifest1
-rw-r--r--dev-python/pyocr/pyocr-0.8.3.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pyocr/Manifest b/dev-python/pyocr/Manifest
index 30b7d81ac1f2..fb705957a712 100644
--- a/dev-python/pyocr/Manifest
+++ b/dev-python/pyocr/Manifest
@@ -1 +1,2 @@
DIST pyocr-0.8.2.tar.gz 67598 BLAKE2B b5cc1338b73f1147195dd094c332836e49189c3fff051de7e634d99de1135b07b1343af3d7c2dcb302e583a0b307c20aa2aaea4e878d6b2325a5aade7e438b23 SHA512 85100aa236bb2c862b5b67137267a657ae88b06eeb9bd1a895c18bfd7318641fa01ea3966499ccdfcc21480522e4996f0e12f2e8931bb455ade3adea428af17d
+DIST pyocr-0.8.3.tar.gz 67625 BLAKE2B 86edfb08519eda73b29b57b57d495c0fa3bebe8b521d96ce4b644d534d2b32e92532e6275f595912c77093eaf0b1f767f08a130605e9b50142fddf77eb570c4d SHA512 aa4f4fcedd668010841d036899bb83bc0fca6499b29ce2f209e538fd3a2448dce2b52721f0b77bc402d9b3f62052af53e25e78780103172623dea1b367caeab1
diff --git a/dev-python/pyocr/pyocr-0.8.3.ebuild b/dev-python/pyocr/pyocr-0.8.3.ebuild
new file mode 100644
index 000000000000..da459ab474c5
--- /dev/null
+++ b/dev-python/pyocr/pyocr-0.8.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="An optical character recognition (OCR) tool wrapper"
+HOMEPAGE="https://gitlab.gnome.org/World/OpenPaperwork/pyocr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cuneiform +tesseract"
+REQUIRED_USE="|| ( cuneiform tesseract )"
+
+RDEPEND="
+ dev-python/pillow[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
+"
+
+# (tests apparently do not require any backend installed)
+distutils_enable_tests unittest
+
+RDEPEND+="
+ cuneiform? ( app-text/cuneiform )
+ tesseract? ( app-text/tesseract )
+"
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}