summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-06-13 11:08:18 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-06-13 11:11:51 +0200
commit8bc16f0eff642b343a9cc908f75b472de9a91676 (patch)
treee9788a0546e5aed18f61ce0df37549ba665a08c6 /dev-python/pyopencl/pyopencl-2016.1.ebuild
parentapp-admin/supervisor: Bump (diff)
downloadgentoo-8bc16f0eff642b343a9cc908f75b472de9a91676.tar.gz
gentoo-8bc16f0eff642b343a9cc908f75b472de9a91676.tar.bz2
gentoo-8bc16f0eff642b343a9cc908f75b472de9a91676.zip
dev-python/pyopencl: Bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-python/pyopencl/pyopencl-2016.1.ebuild')
-rw-r--r--dev-python/pyopencl/pyopencl-2016.1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/pyopencl/pyopencl-2016.1.ebuild b/dev-python/pyopencl/pyopencl-2016.1.ebuild
new file mode 100644
index 000000000000..73512472d6cc
--- /dev/null
+++ b/dev-python/pyopencl/pyopencl-2016.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for OpenCL"
+HOMEPAGE="http://mathema.tician.de/software/pyopencl https://pypi.python.org/pypi/pyopencl"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples opengl"
+
+RDEPEND="
+ >=dev-libs/boost-1.48[python,${PYTHON_USEDEP}]
+ >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/cffi-1.1.0:=[${PYTHON_USEDEP}]
+ >=dev-python/decorator-3.2.0[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pytools-2015.1.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=virtual/opencl-0-r1"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local myconf=()
+ if use opengl; then
+ myconf+=(--cl-enable-gl)
+ fi
+
+ "${PYTHON}" configure.py \
+ --boost-compiler=gcc \
+ --boost-python-libname=boost_python-${PYTHON_ABI}-mt \
+ --no-use-shipped-boost \
+ "${myconf[@]}"
+}
+
+python_install_all() {
+ if use examples; then
+ local EXAMPLES=( examples/. )
+ einfo "Some of the examples provided by this package require dev-python/matplotlib."
+ fi
+ distutils-r1_python_install_all
+}