summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-17 18:17:31 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-17 18:20:22 +0100
commit62ef99690296363865900424a0fb5150d6bed305 (patch)
tree7070239092d5abf05789ebd000d0cb5bb4ee7fd7 /dev-python/pyopenssl/pyopenssl-0.15.1-r1.ebuild
parentdev-perl/Devel-LexAlias: ppc stable wrt bug #570916 (diff)
downloadgentoo-62ef99690296363865900424a0fb5150d6bed305.tar.gz
gentoo-62ef99690296363865900424a0fb5150d6bed305.tar.bz2
gentoo-62ef99690296363865900424a0fb5150d6bed305.zip
dev-python/pyopenssl: Backport fixes for openssl-1.0.2
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pyopenssl/pyopenssl-0.15.1-r1.ebuild')
-rw-r--r--dev-python/pyopenssl/pyopenssl-0.15.1-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/pyopenssl/pyopenssl-0.15.1-r1.ebuild b/dev-python/pyopenssl/pyopenssl-0.15.1-r1.ebuild
new file mode 100644
index 000000000000..0391eff6b536
--- /dev/null
+++ b/dev-python/pyopenssl/pyopenssl-0.15.1-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 flag-o-matic
+
+MY_PN=pyOpenSSL
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python interface to the OpenSSL library"
+HOMEPAGE="
+ http://pyopenssl.sourceforge.net/
+ https://launchpad.net/pyopenssl
+ https://pypi.python.org/pypi/pyOpenSSL
+"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="doc examples"
+
+RDEPEND="
+ >=dev-python/six-1.5.2[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-0.7[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-openssl-1.0.2-backport.patch
+ "${FILESDIR}"/${P}-openssl-1.0.2-backport-1.patch
+ "${FILESDIR}"/${P}-openssl-1.0.2-backport-2.patch
+)
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ esetup.py test
+
+ # https://bugs.launchpad.net/pyopenssl/+bug/1237953
+ rm -rf tmp* *.key *.pem || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}