summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyopenssl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyopenssl')
-rw-r--r--dev-python/pyopenssl/Manifest3
-rw-r--r--dev-python/pyopenssl/metadata.xml9
-rw-r--r--dev-python/pyopenssl/pyopenssl-0.13.1-r1.ebuild77
-rw-r--r--dev-python/pyopenssl/pyopenssl-0.13.1.ebuild75
-rw-r--r--dev-python/pyopenssl/pyopenssl-0.14.ebuild58
-rw-r--r--dev-python/pyopenssl/pyopenssl-0.15.1.ebuild52
6 files changed, 274 insertions, 0 deletions
diff --git a/dev-python/pyopenssl/Manifest b/dev-python/pyopenssl/Manifest
new file mode 100644
index 000000000000..01e9362ba552
--- /dev/null
+++ b/dev-python/pyopenssl/Manifest
@@ -0,0 +1,3 @@
+DIST pyOpenSSL-0.13.1.tar.gz 254431 SHA256 ba06ec710414f6dfe5566ec24c81882547c3e6fc48458d64315b73a0d5142fdb SHA512 5be0fddd0517566fa954e13854a428a21962b13f0c31a8ca0a27d90b74b3a9cfc60e3650e5915a28b3e55b97c655d4a6589122408ef61e6dea509745662bbc0e WHIRLPOOL 5d6500a21ab3808765b9a5cf14beac66b5359ba5c184d0de02839f3f0b7c4935fe4f656577866b6c4f1bae2e1461f4fbb41fb6cb4615c3d02efb408010bc3dc5
+DIST pyOpenSSL-0.14.tar.gz 128005 SHA256 a99db8e59c120138ad8a72eecedcc24b4510d2eed3ce48213b7e32f22cc4ee6e SHA512 afd14aad8f7313425b9f0d79d80fbc17feaf128204cbda21db4116c8ce6e08e77e865110971c02bdc99b27a2d43402cc87f04586375167f41c61d0f474109512 WHIRLPOOL 6d73c560fb2f9adcdf12d92c4d1f20ef62a0284bd8cb3598e48f539cc4c4ee557215251d13f97cda3acc468b89c10e206cd1484eee582b46dca9fc0f6c6b110f
+DIST pyOpenSSL-0.15.1.tar.gz 149887 SHA256 f0a26070d6db0881de8bcc7846934b7c3c930d8f9c79d45883ee48984bc0d672 SHA512 bd204f40c9583a8580cff28b061f02ea772fdda3965dab6ac9e3f8c3b98792bea87b6de76494f7ce81e1ddcc76019432a9ffa3bcd55c5adb063bb639efe62e51 WHIRLPOOL 34badbf11b49cb65019cb55da7c6d6a539971392741d14ea1408c56dc0564d52ffeb947d86549fed17762474d863d59a406cde86daa75a329bd5b6411a77702b
diff --git a/dev-python/pyopenssl/metadata.xml b/dev-python/pyopenssl/metadata.xml
new file mode 100644
index 000000000000..545a1761b785
--- /dev/null
+++ b/dev-python/pyopenssl/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">pyOpenSSL</remote-id>
+ <remote-id type="launchpad">pyopenssl</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyopenssl/pyopenssl-0.13.1-r1.ebuild b/dev-python/pyopenssl/pyopenssl-0.13.1-r1.ebuild
new file mode 100644
index 000000000000..1f4f1072091b
--- /dev/null
+++ b/dev-python/pyopenssl/pyopenssl-0.13.1-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3} pypy )
+
+inherit distutils-r1 flag-o-matic
+
+MY_PN="pyOpenSSL"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python interface to the OpenSSL library"
+HOMEPAGE="http://pyopenssl.sourceforge.net/ https://launchpad.net/pyopenssl http://pypi.python.org/pypi/pyOpenSSL"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/openssl-0.9.6g"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-tex/latex2html-2002.2[gif,png] )"
+
+# pypy* won't fit since CPython 3 is 'better' than it
+REQUIRED_USE="doc? ( || ( $(python_gen_useflags python2*) ) )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ sed \
+ -e "s/test_set_tlsext_host_name_wrong_args/_&/" \
+ -i OpenSSL/test/test_ssl.py || die "test_ssl sed failed"
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ local CFLAGS=${CFLAGS} CXXFLAGS=${CXXFLAGS}
+ [[ ${EPYTHON} != python3* ]] && append-flags -fno-strict-aliasing
+
+ distutils-r1_python_compile
+}
+
+python_compile_all() {
+ if use doc; then
+ addwrite /var/cache/fonts
+
+ cd doc || die
+ emake -j1 html ps dvi
+ fi
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib/OpenSSL/test || die
+
+ local t
+ for t in test_*.py; do
+ "${PYTHON}" "${t}" || die "Test ${t} fails with ${EPYTHON}"
+ done
+ # https://bugs.launchpad.net/pyopenssl/+bug/1237953
+ rm -rf tmp* *.key *.pem
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ dohtml -r doc/html/.
+ dodoc doc/pyOpenSSL.*
+ fi
+
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+}
diff --git a/dev-python/pyopenssl/pyopenssl-0.13.1.ebuild b/dev-python/pyopenssl/pyopenssl-0.13.1.ebuild
new file mode 100644
index 000000000000..4a4ff8dc8e74
--- /dev/null
+++ b/dev-python/pyopenssl/pyopenssl-0.13.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3} pypy )
+
+inherit distutils-r1 flag-o-matic
+
+MY_PN="pyOpenSSL"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python interface to the OpenSSL library"
+HOMEPAGE="http://pyopenssl.sourceforge.net/ https://launchpad.net/pyopenssl http://pypi.python.org/pypi/pyOpenSSL"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/openssl-0.9.6g"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-tex/latex2html-2002.2[gif,png] )"
+
+# pypy* won't fit since CPython 3 is 'better' than it
+REQUIRED_USE="doc? ( || ( $(python_gen_useflags python2*) ) )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ sed \
+ -e "s/test_set_tlsext_host_name_wrong_args/_&/" \
+ -i OpenSSL/test/test_ssl.py || die "test_ssl sed failed"
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ local CFLAGS=${CFLAGS} CXXFLAGS=${CXXFLAGS}
+ [[ ${EPYTHON} != python3* ]] && append-flags -fno-strict-aliasing
+
+ distutils-r1_python_compile
+}
+
+python_compile_all() {
+ if use doc; then
+ addwrite /var/cache/fonts
+
+ cd doc || die
+ emake -j1 html ps dvi
+ fi
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib/OpenSSL/test || die
+
+ local t
+ for t in test_*.py; do
+ "${PYTHON}" "${t}" || die "Test ${t} fails with ${EPYTHON}"
+ done
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ dohtml -r doc/html/.
+ dodoc doc/pyOpenSSL.*
+ fi
+
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+}
diff --git a/dev-python/pyopenssl/pyopenssl-0.14.ebuild b/dev-python/pyopenssl/pyopenssl-0.14.ebuild
new file mode 100644
index 000000000000..755c3046dbd7
--- /dev/null
+++ b/dev-python/pyopenssl/pyopenssl-0.14.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1 flag-o-matic
+
+MY_PN=pyOpenSSL
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python interface to the OpenSSL library"
+HOMEPAGE="http://pyopenssl.sourceforge.net/ https://launchpad.net/pyopenssl http://pypi.python.org/pypi/pyOpenSSL"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="doc examples"
+
+RDEPEND="
+ >=dev-python/six-1.5.2[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-0.2.1-r2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}
+
+python_prepare_all() {
+ sed \
+ -e "s/test_set_tlsext_host_name_wrong_args/_&/" \
+ -i OpenSSL/test/test_ssl.py || die "test_ssl sed failed"
+
+ # https://github.com/pyca/pyopenssl/issues/41
+ sed -e "s/test_digest/_&/" -i OpenSSL/test/test_crypto.py
+ # https://github.com/pyca/pyopenssl/issues/67
+ sed -e "s/test_wantWriteError/_&/" -i OpenSSL/test/test_ssl.py
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ esetup.py test
+
+ # https://bugs.launchpad.net/pyopenssl/+bug/1237953
+ rm -rf tmp* *.key *.pem
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pyopenssl/pyopenssl-0.15.1.ebuild b/dev-python/pyopenssl/pyopenssl-0.15.1.ebuild
new file mode 100644
index 000000000000..dbf10bb0006c
--- /dev/null
+++ b/dev-python/pyopenssl/pyopenssl-0.15.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1 flag-o-matic
+
+MY_PN=pyOpenSSL
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python interface to the OpenSSL library"
+HOMEPAGE="http://pyopenssl.sourceforge.net/ https://launchpad.net/pyopenssl http://pypi.python.org/pypi/pyOpenSSL"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="doc examples"
+
+RDEPEND="
+ >=dev-python/six-1.5.2[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-0.7[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}
+
+python_prepare_all() {
+ # https://github.com/pyca/pyopenssl/issues/41
+ sed -e "s/test_digest/_&/" -i OpenSSL/test/test_crypto.py
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ esetup.py test
+
+ # https://bugs.launchpad.net/pyopenssl/+bug/1237953
+ rm -rf tmp* *.key *.pem
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}