summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-14 07:23:06 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-14 07:31:40 +0100
commit19eea8bb3614cf204f3532b3ff2830cee260f44c (patch)
treed15a788a5215155a93eae0288766fc24dff80d61 /dev-python/pyotp/pyotp-2.8.0.ebuild
parentdev-python/traitlets: Bump to 5.7.1 (diff)
downloadgentoo-19eea8bb3614cf204f3532b3ff2830cee260f44c.tar.gz
gentoo-19eea8bb3614cf204f3532b3ff2830cee260f44c.tar.bz2
gentoo-19eea8bb3614cf204f3532b3ff2830cee260f44c.zip
dev-python/pyotp: Bump to 2.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyotp/pyotp-2.8.0.ebuild')
-rw-r--r--dev-python/pyotp/pyotp-2.8.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/pyotp/pyotp-2.8.0.ebuild b/dev-python/pyotp/pyotp-2.8.0.ebuild
new file mode 100644
index 000000000000..1309f77d2d96
--- /dev/null
+++ b/dev-python/pyotp/pyotp-2.8.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="PyOTP is a Python library for generating and verifying one-time passwords"
+HOMEPAGE="
+ https://github.com/pyauth/pyotp/
+ https://pypi.org/project/pyotp/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests unittest