summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-15 16:04:45 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-15 16:41:21 +0200
commitfd11aad3a8c898c64f6cf7c0da29fa8cde63ebeb (patch)
tree0e84f31f86dd93916f9449fae705228a5641b8c6 /dev-python/pyparsing/pyparsing-2.0.3.ebuild
parentdev-python/PyContracts: New package, ebuild written by me (diff)
downloadgentoo-fd11aad3a8c898c64f6cf7c0da29fa8cde63ebeb.tar.gz
gentoo-fd11aad3a8c898c64f6cf7c0da29fa8cde63ebeb.tar.bz2
gentoo-fd11aad3a8c898c64f6cf7c0da29fa8cde63ebeb.zip
dev-python/pyparsing: Add python3.5 support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pyparsing/pyparsing-2.0.3.ebuild')
-rw-r--r--dev-python/pyparsing/pyparsing-2.0.3.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-python/pyparsing/pyparsing-2.0.3.ebuild b/dev-python/pyparsing/pyparsing-2.0.3.ebuild
index b03dbc1948de..7a482c2650b8 100644
--- a/dev-python/pyparsing/pyparsing-2.0.3.ebuild
+++ b/dev-python/pyparsing/pyparsing-2.0.3.ebuild
@@ -3,7 +3,8 @@
# $Id$
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
inherit distutils-r1
@@ -18,6 +19,9 @@ IUSE="doc examples"
RDEPEND="!dev-python/pyparsing:py2 !dev-python/pyparsing:py3"
+# no contained in the tarball
+RESTRICT=test
+
python_install_all() {
local HTML_DOCS=( HowToUsePyparsing.html )
if use doc; then
@@ -27,3 +31,7 @@ python_install_all() {
use examples && local EXAMPLES=( examples/. )
distutils-r1_python_install_all
}
+
+python_test() {
+ ${PYTHON} unitTests.py || die
+}