summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-27 19:21:27 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-27 19:47:37 +0200
commit2cbdc93cd725c780e5049b8f01493c22c978a0f8 (patch)
treefc97b8bf03205d9a9d7e7e7d56f8f2cc74ed9a4e /dev-python/pyparsing/pyparsing-2.4.7-r1.ebuild
parentdev-db/mongodb: drop CVE-2020-7923 vulnerable versio #738760 (diff)
downloadgentoo-2cbdc93cd725c780e5049b8f01493c22c978a0f8.tar.gz
gentoo-2cbdc93cd725c780e5049b8f01493c22c978a0f8.tar.bz2
gentoo-2cbdc93cd725c780e5049b8f01493c22c978a0f8.zip
dev-python/pyparsing: Remove py2.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyparsing/pyparsing-2.4.7-r1.ebuild')
-rw-r--r--dev-python/pyparsing/pyparsing-2.4.7-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pyparsing/pyparsing-2.4.7-r1.ebuild b/dev-python/pyparsing/pyparsing-2.4.7-r1.ebuild
new file mode 100644
index 000000000000..7007a149ec66
--- /dev/null
+++ b/dev-python/pyparsing/pyparsing-2.4.7-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2004-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1
+
+MY_P=${P/-/_}
+DESCRIPTION="Easy-to-use Python module for text parsing"
+HOMEPAGE="https://github.com/pyparsing/pyparsing https://pypi.org/project/pyparsing/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${MY_P}.tar.gz"
+# pypi releases and generated github tarballs lack tests
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples"
+
+distutils_enable_tests setup.py
+
+S=${WORKDIR}/${PN}-${MY_P}
+
+python_install_all() {
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}