summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-04-11 23:52:30 -0500
committerTim Harder <radhermit@gentoo.org>2019-04-11 23:52:30 -0500
commit65e20612ad4bc79de04cf909b5cfe07ffbbbee08 (patch)
tree3048fbfb1f353f717d4b2b2c7c445bdf4ff36fed /dev-python/pyparsing
parentdev-python/psutil: version bump to 5.6.1 (diff)
downloadgentoo-65e20612ad4bc79de04cf909b5cfe07ffbbbee08.tar.gz
gentoo-65e20612ad4bc79de04cf909b5cfe07ffbbbee08.tar.bz2
gentoo-65e20612ad4bc79de04cf909b5cfe07ffbbbee08.zip
dev-python/pyparsing: version bump to 2.4.0
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-python/pyparsing')
-rw-r--r--dev-python/pyparsing/Manifest1
-rw-r--r--dev-python/pyparsing/pyparsing-2.4.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pyparsing/Manifest b/dev-python/pyparsing/Manifest
index d9646c7cdaa4..71929677e9d3 100644
--- a/dev-python/pyparsing/Manifest
+++ b/dev-python/pyparsing/Manifest
@@ -1,3 +1,4 @@
DIST pyparsing-2.2.0.tar.gz 1232522 BLAKE2B 59420548fcee047e2b385d76b8ce034807eb3ac0fcdc9929f656cf4b81436c96c37d206b5d6b90ee6892e402df6b939fe9e793384d4cbe0618c8d06d5197586d SHA512 6a409f429d40a5ac202d144e4150de2c80d7c7120147f603f72a4a99797d48c50822a6437f590ec5ae4418d51aa1f6b1d4e5d95a57e19bec0a127b04e4937008
DIST pyparsing_2.3.0.tar.gz 624393 BLAKE2B 9fd9bee7742953d455ea34310ef1668df0a7633642deb4eeff507439228ae018e4ba99d3476c5cfe374a908b58b0311527ae5f04ddec8eb7e219a2a9d4cbc8ce SHA512 2a4de9b208ee3c557fb6d050d5c3c20e35a11b21d35996fce5a0876d4f52952072bed7ae2ed157ae0ba388543dc554f4828a1da22712ae7d9f0d38a16b0a546e
DIST pyparsing_2.3.1.tar.gz 619405 BLAKE2B 4c1b9abe6ce6e511a998eff19eb32c835144473bfe47204880f43979b1ad72f5c73ff72bfc17fcaa3cf2a9b52875f184b122927cc0d9f9eca5cc4facdc4a119d SHA512 8c0e2c7a7dc7ec12f3e7c260bde25a33f325af89d9bc2329b7882ebd8a3f506fb06a36fdaba0fd8ed48040d5b7fc5288c41b01f2df84459a9980a035cb213dd0
+DIST pyparsing_2.4.0.tar.gz 625419 BLAKE2B 5555a255cbfcbb076fe4d385b2da967bc44a7110acdd1a4715fb3e22db2a3f5b7bef1ad61423f6d0419cd8cb403abe222e426a96ea755044d04e0105c2798317 SHA512 2888b60c2518b19979e00b01ea499c45cd0a98affe0551f80ea7985acd649d62b4e231e142d3efd65cdcd9e3a0182680bfe1c4d98e310fa2ac476f37ac4ff344
diff --git a/dev-python/pyparsing/pyparsing-2.4.0.ebuild b/dev-python/pyparsing/pyparsing-2.4.0.ebuild
new file mode 100644
index 000000000000..7e9dae9a2771
--- /dev/null
+++ b/dev-python/pyparsing/pyparsing-2.4.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2004-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P/-/_}
+DESCRIPTION="Easy-to-use Python module for text parsing"
+HOMEPAGE="https://github.com/pyparsing/pyparsing https://pypi.org/project/pyparsing/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${MY_P}.tar.gz"
+# pypi releases and generated github tarballs lack tests
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples"
+
+# setuptools currently vendors its own copy of pyparsing to avoid bootstrapping
+# issues so depend on it here for consistency
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+S=${WORKDIR}/${PN}-${MY_P}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}