summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-04-08 20:53:32 +0200
committerSebastian Pipping <sping@gentoo.org>2020-04-08 20:53:55 +0200
commitff8b4c20acfd6ed8993cbd246f2c38ae042bc726 (patch)
treef4d24ba553989be83dceeaa1e8f597b3d09c9c7f /dev-python/pyparsing
parentapp-emulation/qemu: fix buffer overflow, CVE-2020-11102 (diff)
downloadgentoo-ff8b4c20acfd6ed8993cbd246f2c38ae042bc726.tar.gz
gentoo-ff8b4c20acfd6ed8993cbd246f2c38ae042bc726.tar.bz2
gentoo-ff8b4c20acfd6ed8993cbd246f2c38ae042bc726.zip
dev-python/pyparsing: 2.4.7
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.96, Repoman-2.3.22
Diffstat (limited to 'dev-python/pyparsing')
-rw-r--r--dev-python/pyparsing/Manifest1
-rw-r--r--dev-python/pyparsing/pyparsing-2.4.7.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pyparsing/Manifest b/dev-python/pyparsing/Manifest
index cf6a79c6692c..107947f9b7af 100644
--- a/dev-python/pyparsing/Manifest
+++ b/dev-python/pyparsing/Manifest
@@ -1 +1,2 @@
DIST pyparsing_2.4.6.tar.gz 647543 BLAKE2B f6c93fa1e9a7ece4cf6abcc74dae0c96becaf7f50eed5437a6410166e80768c17d429fa2d1e4d1958b2a7c5ad6ffd18218c5160bb0ebe03ae2963014612eecf3 SHA512 475b77f469d2051fb067796849f7c7d3df145f2c6cefc708c904a5b0af22661b4c229c521c2cac3c94621dde9bda6b28e428a8e31d936df6d4596d993263981e
+DIST pyparsing_2.4.7.tar.gz 648158 BLAKE2B 24525b4ee7876e245b9eb270f0e3e22fe2d8b398f9777ad3b3657b8a1227dcbd25983aa64a3f3018debdbffc1a042c732e6b3a09800e081c7acac7b97da15317 SHA512 c7a546729f86a2b5176e2482b566b9fd715b03e495aaef4d720b21307bb03f385dbc849247f8d266cb3d92be0a83c34ce4995b655ce85318355d5a0d42d6991e
diff --git a/dev-python/pyparsing/pyparsing-2.4.7.ebuild b/dev-python/pyparsing/pyparsing-2.4.7.ebuild
new file mode 100644
index 000000000000..e0fceaa8ab24
--- /dev/null
+++ b/dev-python/pyparsing/pyparsing-2.4.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2004-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1
+
+MY_P=${P/-/_}
+DESCRIPTION="Easy-to-use Python module for text parsing"
+HOMEPAGE="https://github.com/pyparsing/pyparsing https://pypi.org/project/pyparsing/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${MY_P}.tar.gz"
+# pypi releases and generated github tarballs lack tests
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples"
+
+distutils_enable_tests setup.py
+
+S=${WORKDIR}/${PN}-${MY_P}
+
+python_install_all() {
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}