summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-20 15:53:46 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-20 15:53:46 +0200
commit388ee9d1a91208efe0038c679e5f16f5b29d65f9 (patch)
treed7516c525f569ab63a33a92334f573a1b0a2f4e2 /dev-python/pyparted/pyparted-3.13.0.ebuild
parentdev-python/pyocr: Remove old (diff)
downloadgentoo-388ee9d1a91208efe0038c679e5f16f5b29d65f9.tar.gz
gentoo-388ee9d1a91208efe0038c679e5f16f5b29d65f9.tar.bz2
gentoo-388ee9d1a91208efe0038c679e5f16f5b29d65f9.zip
dev-python/pyparted: Bump to 3.13.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyparted/pyparted-3.13.0.ebuild')
-rw-r--r--dev-python/pyparted/pyparted-3.13.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pyparted/pyparted-3.13.0.ebuild b/dev-python/pyparted/pyparted-3.13.0.ebuild
new file mode 100644
index 000000000000..c2c64b39a2ca
--- /dev/null
+++ b/dev-python/pyparted/pyparted-3.13.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for sys-block/parted"
+HOMEPAGE="
+ https://github.com/dcantrell/pyparted/
+ https://pypi.org/project/pyparted/
+"
+SRC_URI="
+ https://github.com/dcantrell/pyparted/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="
+ >=sys-block/parted-3.4
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+distutils_enable_tests unittest