summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-11-28 16:48:40 -0500
committerAnthony G. Basile <blueness@gentoo.org>2018-11-28 16:48:40 -0500
commit2b3e01eb2245b331d74081dad921553dc6e4ab5a (patch)
tree753c33b0936594e390d32a3050e9dd161ee3ae4a /dev-python/pypax/pypax-0.9.3.ebuild
parentsys-kernel/gentoo-sources-4.4.164-r0: alpha stable (diff)
downloadgentoo-2b3e01eb2245b331d74081dad921553dc6e4ab5a.tar.gz
gentoo-2b3e01eb2245b331d74081dad921553dc6e4ab5a.tar.bz2
gentoo-2b3e01eb2245b331d74081dad921553dc6e4ab5a.zip
dev-python/pypax: version bump to 0.9.3, fixes bug #648454
Closes: https://bugs.gentoo.org/648454 Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-python/pypax/pypax-0.9.3.ebuild')
-rw-r--r--dev-python/pypax/pypax-0.9.3.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pypax/pypax-0.9.3.ebuild b/dev-python/pypax/pypax-0.9.3.ebuild
new file mode 100644
index 000000000000..e803f0780cbd
--- /dev/null
+++ b/dev-python/pypax/pypax-0.9.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/elfix.git"
+ inherit git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~blueness/elfix/elfix-${PV}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+ S="${WORKDIR}/elfix-${PV}"
+fi
+
+DESCRIPTION="Python module to get or set either PT_PAX and/or XATTR_PAX flags"
+HOMEPAGE="https://dev.gentoo.org/~blueness/elfix/
+ https://www.gentoo.org/proj/en/hardened/pax-quickstart.xml"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="+ptpax +xtpax"
+
+REQUIRED_USE="|| ( ptpax xtpax )"
+
+RDEPEND="
+ ptpax? ( dev-libs/elfutils )
+ xtpax? ( sys-apps/attr )"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${RDEPEND}"
+
+src_compile() {
+ cd scripts || die
+ unset PTPAX
+ unset XTPAX
+ use ptpax && export PTPAX="yes"
+ use xtpax && export XTPAX="yes"
+ distutils-r1_src_compile
+}
+
+src_install() {
+ cd scripts || die
+ distutils-r1_src_install
+}