summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-07-04 08:52:45 -0600
committerTim Harder <radhermit@gentoo.org>2019-07-04 08:54:23 -0600
commit5b0cbd6b193e7227f3844a303ec63c83cf289a46 (patch)
treea505234ca0c158b3005e542d7ee6380ce35d5ff3 /dev-python/pyperclip
parentmedia-tv/kodi: Add raspberry-pi USE flag (diff)
downloadgentoo-5b0cbd6b193e7227f3844a303ec63c83cf289a46.tar.gz
gentoo-5b0cbd6b193e7227f3844a303ec63c83cf289a46.tar.bz2
gentoo-5b0cbd6b193e7227f3844a303ec63c83cf289a46.zip
dev-python/pyperclip: version bump to 1.7.0
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-python/pyperclip')
-rw-r--r--dev-python/pyperclip/Manifest1
-rw-r--r--dev-python/pyperclip/pyperclip-1.7.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pyperclip/Manifest b/dev-python/pyperclip/Manifest
index c6f854a5827f..a7663cd92879 100644
--- a/dev-python/pyperclip/Manifest
+++ b/dev-python/pyperclip/Manifest
@@ -1,3 +1,4 @@
DIST pyperclip-1.5.27.zip 16938 BLAKE2B 653b2e74b6f56839ef1f9d59b864218ffd55866660aa7de4284f0bab4c28b0c1aa7a4a65bce0842003d4744a5d40c87943e05bdea13098e250e534a8cb6c2132 SHA512 cefd79f1d246c9aa9d4d0f3d8cdad291ad31bcc2e000c83e5e05704978bbf7b9b45d49667c2e88305d0a5d6baaeacfb47b26bb69fabf89b6b6e3a1e6f1e23d74
DIST pyperclip-1.6.0.tar.gz 14273 BLAKE2B e91f198d23eb0791dc610e4b9af940694f0857243fbf5caf46d485882a588e3ab537e2a190a1b40e0d9ff4821c8bf977da19559a5b33694d106a68f1001f61a9 SHA512 faf1cd8568a911b263c167fedace8f5f6756e108e3a2484dffa8d3da441311fb3277fd703d5eaea662181250d7b2cc975e9f8ca484dfa2d1cd4470171bbb972d
DIST pyperclip-1.6.4.tar.gz 15687 BLAKE2B e3520e228bfe2f2de1d307e927f15cee7e5327acfe07071432605d0c0c021ff6bb702e20a743da8120db58fd12a05fca19f5881e80851f41d2cc1034e310f6fd SHA512 4a07476b96fc704551248eb4eb2d69a910f75c266ef0adf4bf804f8694645d910089cfef831569e1d819570873ee75c4339024a89c56fe3eabc5529d07b8a540
+DIST pyperclip-1.7.0.tar.gz 15977 BLAKE2B da1473f71bcadcc6dcacdfb6d1a1447b055eb1aa7b31fad76bd3a51245ad9b1e512335f9799d7d416a53b8471ab66c28afa5f9d3f3ee2b39e85d9c239a7e2c79 SHA512 7f22227ea894a236703f61ab950e198fab969fac5713ca8eac6df213183a47a244add88a462b9ddf63ed5bec36af5bc2578949f01ed31e0b63316d1761a935bd
diff --git a/dev-python/pyperclip/pyperclip-1.7.0.ebuild b/dev-python/pyperclip/pyperclip-1.7.0.ebuild
new file mode 100644
index 000000000000..6b173121f867
--- /dev/null
+++ b/dev-python/pyperclip/pyperclip-1.7.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy)
+inherit distutils-r1 virtualx
+
+DESCRIPTION="A cross-platform clipboard module for Python."
+HOMEPAGE="https://github.com/asweigart/pyperclip"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ || (
+ x11-misc/xclip
+ x11-misc/xsel
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/pygtk[${PYTHON_USEDEP}]' python2_7)
+ )
+"
+
+python_prepare_all() {
+ # make tests a proper module so setuptools can find the test suite
+ touch tests/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ virtx esetup.py test
+}