summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-29 09:56:04 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 09:56:28 +0100
commita6c172605c803abb2d707a8135f3500fcaf78c97 (patch)
tree6650478e32aa14eadfeb918238d66e5f88221d5b /dev-python/pypng
parentwww-client/chromium: beta channel bump to 98.0.4758.74 (diff)
downloadgentoo-a6c172605c803abb2d707a8135f3500fcaf78c97.tar.gz
gentoo-a6c172605c803abb2d707a8135f3500fcaf78c97.tar.bz2
gentoo-a6c172605c803abb2d707a8135f3500fcaf78c97.zip
dev-python/pypng: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pypng')
-rw-r--r--dev-python/pypng/pypng-0.0.21-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pypng/pypng-0.0.21-r1.ebuild b/dev-python/pypng/pypng-0.0.21-r1.ebuild
new file mode 100644
index 000000000000..39d92271eef7
--- /dev/null
+++ b/dev-python/pypng/pypng-0.0.21-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure Python PNG image encoder/decoder"
+HOMEPAGE="
+ https://github.com/drj11/pypng/
+ https://pypi.org/project/pypng/"
+SRC_URI="https://github.com/drj11/pypng/archive/${P}.tar.gz"
+S=${WORKDIR}/pypng-${P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+python_test() {
+ "${EPYTHON}" code/test_png.py -v || die "Tests fail with ${EPYTHON}"
+}