summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-28 21:31:17 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-28 21:32:24 +0300
commit06c8da2d11122daad32104a1ab0e7078620508d5 (patch)
treecafa9baffcdf752e8cefea5366a1a062c9c8c63a /dev-python/pyprof2calltree
parentnet-misc/electron-cash: remove audio_modem USE flag (diff)
downloadgentoo-06c8da2d11122daad32104a1ab0e7078620508d5.tar.gz
gentoo-06c8da2d11122daad32104a1ab0e7078620508d5.tar.bz2
gentoo-06c8da2d11122daad32104a1ab0e7078620508d5.zip
dev-python/pyprof2calltree: EAPI=8, PEP517, cleanup
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pyprof2calltree')
-rw-r--r--dev-python/pyprof2calltree/pyprof2calltree-1.4.5-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/pyprof2calltree/pyprof2calltree-1.4.5-r1.ebuild b/dev-python/pyprof2calltree/pyprof2calltree-1.4.5-r1.ebuild
new file mode 100644
index 000000000000..977ffebb4c69
--- /dev/null
+++ b/dev-python/pyprof2calltree/pyprof2calltree-1.4.5-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="convert python profile data to kcachegrind calltree form"
+HOMEPAGE="https://pypi.org/project/pyprof2calltree/"
+# pypi tarball lacks tests
+SRC_URI="https://github.com/pwaller/pyprof2calltree/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests unittest