summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-14 06:04:01 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-14 06:05:36 +0100
commit81d87530e4d3294cdebde899165d54fc8a3c2e88 (patch)
treee7140644c30ae155af8f3638480f567e969b8e42 /dev-python/pyproject-fmt/pyproject-fmt-0.9.1.ebuild
parentdev-python/awxkit: Bump to 21.12.0 (diff)
downloadgentoo-81d87530e4d3294cdebde899165d54fc8a3c2e88.tar.gz
gentoo-81d87530e4d3294cdebde899165d54fc8a3c2e88.tar.bz2
gentoo-81d87530e4d3294cdebde899165d54fc8a3c2e88.zip
dev-python/pyproject-fmt: Bump to 0.9.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyproject-fmt/pyproject-fmt-0.9.1.ebuild')
-rw-r--r--dev-python/pyproject-fmt/pyproject-fmt-0.9.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pyproject-fmt/pyproject-fmt-0.9.1.ebuild b/dev-python/pyproject-fmt/pyproject-fmt-0.9.1.ebuild
new file mode 100644
index 000000000000..a802c14c305f
--- /dev/null
+++ b/dev-python/pyproject-fmt/pyproject-fmt-0.9.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Format your pyproject.toml file"
+HOMEPAGE="
+ https://github.com/tox-dev/pyproject-fmt/
+ https://pypi.org/project/pyproject-fmt/
+"
+SRC_URI="
+ https://github.com/tox-dev/pyproject-fmt/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-23[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.11.6[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-mock-3.10[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}