summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-28 18:11:31 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-28 18:53:04 +0200
commitd63903d7fa4d1452f5848649ef5b0ec1afa6c30b (patch)
tree42ee944ca1e607a3d5232739d9e21ab7f76f3549 /dev-python/pyproject-fmt/pyproject-fmt-1.1.0.ebuild
parentdev-python/pyghmi: Bump to 1.5.63 (diff)
downloadgentoo-d63903d7fa4d1452f5848649ef5b0ec1afa6c30b.tar.gz
gentoo-d63903d7fa4d1452f5848649ef5b0ec1afa6c30b.tar.bz2
gentoo-d63903d7fa4d1452f5848649ef5b0ec1afa6c30b.zip
dev-python/pyproject-fmt: Bump to 1.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyproject-fmt/pyproject-fmt-1.1.0.ebuild')
-rw-r--r--dev-python/pyproject-fmt/pyproject-fmt-1.1.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pyproject-fmt/pyproject-fmt-1.1.0.ebuild b/dev-python/pyproject-fmt/pyproject-fmt-1.1.0.ebuild
new file mode 100644
index 000000000000..c440d098979a
--- /dev/null
+++ b/dev-python/pyproject-fmt/pyproject-fmt-1.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Format your pyproject.toml file"
+HOMEPAGE="
+ https://github.com/tox-dev/pyproject-fmt/
+ https://pypi.org/project/pyproject-fmt/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/natsort[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+"
+# tox is called as a subprocess, to get targets from tox.ini
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-mock-3.10[${PYTHON_USEDEP}]
+ dev-python/tox
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # upstream lower bounds are completely meaningless and copying them
+ # to the ebuild is a horrible waste of time
+ sed -i -e 's:>=[0-9.]*::' pyproject.toml || die
+ distutils-r1_src_prepare
+}