summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyprotocols
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyprotocols')
-rw-r--r--dev-python/pyprotocols/Manifest1
-rw-r--r--dev-python/pyprotocols/files/SkipTests.patch26
-rw-r--r--dev-python/pyprotocols/metadata.xml5
-rw-r--r--dev-python/pyprotocols/pyprotocols-1.0_pre2306-r1.ebuild45
4 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/pyprotocols/Manifest b/dev-python/pyprotocols/Manifest
new file mode 100644
index 000000000000..d4320d036cc2
--- /dev/null
+++ b/dev-python/pyprotocols/Manifest
@@ -0,0 +1 @@
+DIST PyProtocols-1.0a0dev_r2306.tar.gz 218555 SHA256 55241280fdb5c9a00e69c51e0fca2d76214d741843753f00c73bf78ea09db284 SHA512 1f18be9548ae29b6111dccd158f5706f3a1ed7074152e9ef2e0d17caaad2227d3f613b50b602b3b1d47b5db7f53e583fce4e06b3e23916ac0daf7a92bcd66ccc WHIRLPOOL 150bedb9f3f531104efb30bc7c49f1dbfbb6bdde32bb706273c8f0c2513e951fa80bf992b4f58e151185ebfaf26df70aecd5b84e1ba55cf907ee78e9c5788f65
diff --git a/dev-python/pyprotocols/files/SkipTests.patch b/dev-python/pyprotocols/files/SkipTests.patch
new file mode 100644
index 000000000000..7e362678fe4f
--- /dev/null
+++ b/dev-python/pyprotocols/files/SkipTests.patch
@@ -0,0 +1,26 @@
+diff -ur PyProtocols.orig/src/protocols/tests/__init__.py PyProtocols/src/protocols/tests/__init__.py
+--- src/protocols/tests/__init__.py 2007-04-25 12:15:46.000000000 +0800
++++ src/protocols/tests/__init__.py 2013-04-10 19:22:28.720647271 +0800
+@@ -256,22 +256,6 @@
+ makeSuite(GenerationTests,'check'),
+ ]
+
+- try:
+- import zope.interface
+- except ImportError:
+- pass
+- else:
+- from protocols.tests import test_zope
+- tests.append( test_zope.test_suite() )
+-
+- try:
+- from twisted.python.components import Interface
+- except (ImportError, SystemError):
+- pass
+- else:
+- from protocols.tests import test_twisted
+- tests.append( test_twisted.test_suite() )
+-
+ return TestSuite(
+ tests
+ )
diff --git a/dev-python/pyprotocols/metadata.xml b/dev-python/pyprotocols/metadata.xml
new file mode 100644
index 000000000000..de483c53568f
--- /dev/null
+++ b/dev-python/pyprotocols/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/pyprotocols/pyprotocols-1.0_pre2306-r1.ebuild b/dev-python/pyprotocols/pyprotocols-1.0_pre2306-r1.ebuild
new file mode 100644
index 000000000000..6868e3adee72
--- /dev/null
+++ b/dev-python/pyprotocols/pyprotocols-1.0_pre2306-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 flag-o-matic eutils
+
+MY_PN="PyProtocols"
+MY_P="${MY_PN}-${PV/_pre/a0dev_r}"
+
+DESCRIPTION="Extends the PEP 246 adapt function with a new 'declaration API'"
+HOMEPAGE="http://peak.telecommunity.com/PyProtocols.html http://pypi.python.org/pypi/PyProtocols \
+ http://svn.eby-sarna.com/PyProtocols/"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+
+LICENSE="|| ( PSF-2 ZPL )"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ppc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND=">=dev-python/decoratortools-1.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=dev-python/pyrex-0.9.9[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_PN}"
+
+DOCS=( CHANGES.txt README.txt UPGRADING.txt )
+
+python_prepare_all() {
+ # Rm peripheral & rogue failing tests
+ rm -f src//protocols/tests/{test_twisted.py,test_zope.py} || die
+ epatch "${FILESDIR}"/SkipTests.patch
+}
+
+python_configure_all() {
+ append-flags -fno-strict-aliasing
+}
+
+python_test() {
+ esetup.py test && einfo "Tests passed under ${EPYTHON}" \
+ || die "Tests failed under ${EPYTHON}"
+}