summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-04-24 18:39:40 +0200
committerMichał Górny <mgorny@gentoo.org>2017-04-25 23:49:10 +0200
commit7bbc0b0897116daafbf21c73178d641bb20f46a5 (patch)
treef29fde739790a3d97a3e4c09ed5bbe1b55f6e0b8 /dev-python/pypy/pypy-9999.ebuild
parentdev-python/pypy: Upstream deprecated asmgc, and defaults to shadowstack (diff)
downloadgentoo-7bbc0b0897116daafbf21c73178d641bb20f46a5.tar.gz
gentoo-7bbc0b0897116daafbf21c73178d641bb20f46a5.tar.bz2
gentoo-7bbc0b0897116daafbf21c73178d641bb20f46a5.zip
dev-python/pypy: Switch 9999 to cpy2.7.13 patchset
Use the patchset from CPython 2.7.13 to avoid keeping old patches around. Disable the Turkish locale patch since it now alters the C sources of CPython -- we need to figure out if pypy needs similar alteration at all, and port it if necessary.
Diffstat (limited to 'dev-python/pypy/pypy-9999.ebuild')
-rw-r--r--dev-python/pypy/pypy-9999.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/pypy/pypy-9999.ebuild b/dev-python/pypy/pypy-9999.ebuild
index e3f07058ffb0..4cda2cf09a0e 100644
--- a/dev-python/pypy/pypy-9999.ebuild
+++ b/dev-python/pypy/pypy-9999.ebuild
@@ -8,13 +8,13 @@ EHG_REPO_URI="https://bitbucket.org/pypy/pypy"
inherit check-reqs eutils mercurial multilib multiprocessing pax-utils python-any-r1 toolchain-funcs versionator
# note: remember to update this to newest dev-lang/python:2.7 on bump
-CPY_PATCHSET_VERSION="2.7.11-0"
+CPY_PATCHSET_VERSION="2.7.13-0"
MY_P=pypy2-v${PV}
DESCRIPTION="A fast, compliant alternative implementation of the Python language"
HOMEPAGE="http://pypy.org/"
SRC_URI="
- https://dev.gentoo.org/~djc/python-gentoo-patches-${CPY_PATCHSET_VERSION}.tar.xz"
+ https://dev.gentoo.org/~floppym/python/python-gentoo-patches-${CPY_PATCHSET_VERSION}.tar.xz"
LICENSE="MIT"
# pypy -c 'import sysconfig; print sysconfig.get_config_var("SOABI")'
@@ -103,8 +103,9 @@ src_prepare() {
# apply CPython stdlib patches
pushd lib-python/2.7 > /dev/null || die
+ # TODO: cpy turkish locale patch now fixes C code
+ # probably needs better port to pypy, if it is broken there
epatch "${FILESDIR}"/5.6.0_all_distutils_cxx.patch \
- "${WORKDIR}"/patches/22_all_turkish_locale.patch \
"${WORKDIR}"/patches/62_all_xml.use_pyxml.patch
popd > /dev/null || die