summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-03-08 09:51:15 +0100
committerMichał Górny <mgorny@gentoo.org>2017-03-08 12:32:41 +0100
commita5bfdb537cfc5c2afe96245ea1ce64cd14ca42ab (patch)
tree50f6d3533cfebba46d0d89277bb5ce2b3d797205 /dev-python/pypy/pypy-9999.ebuild
parentmedia-libs/mutagen: Removed old. (diff)
downloadgentoo-a5bfdb537cfc5c2afe96245ea1ce64cd14ca42ab.tar.gz
gentoo-a5bfdb537cfc5c2afe96245ea1ce64cd14ca42ab.tar.bz2
gentoo-a5bfdb537cfc5c2afe96245ea1ce64cd14ca42ab.zip
dev-python/pypy: Sync the live ebuild
Diffstat (limited to 'dev-python/pypy/pypy-9999.ebuild')
-rw-r--r--dev-python/pypy/pypy-9999.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/dev-python/pypy/pypy-9999.ebuild b/dev-python/pypy/pypy-9999.ebuild
index 934901318e84..de88fb98a5f1 100644
--- a/dev-python/pypy/pypy-9999.ebuild
+++ b/dev-python/pypy/pypy-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -7,15 +7,18 @@ PYTHON_COMPAT=( python2_7 pypy )
EHG_REPO_URI="https://bitbucket.org/pypy/pypy"
inherit check-reqs eutils mercurial multilib multiprocessing pax-utils python-any-r1 toolchain-funcs versionator
-CPY_PATCHSET_VERSION="2.7.10-0"
+# note: remember to update this to newest dev-lang/python:2.7 on bump
+CPY_PATCHSET_VERSION="2.7.11-0"
+MY_P=pypy2-v${PV}
DESCRIPTION="A fast, compliant alternative implementation of the Python language"
HOMEPAGE="http://pypy.org/"
SRC_URI="
- https://dev.gentoo.org/~floppym/python/python-gentoo-patches-${CPY_PATCHSET_VERSION}.tar.xz"
+ https://dev.gentoo.org/~djc/python-gentoo-patches-${CPY_PATCHSET_VERSION}.tar.xz"
LICENSE="MIT"
-SLOT="0/$(get_version_component_range 1-2 ${PV})"
+# pypy -c 'import sysconfig; print sysconfig.get_config_var("SOABI")'
+SLOT="0/41"
KEYWORDS=""
IUSE="bzip2 doc gdbm +jit libressl low-memory ncurses sandbox +shadowstack sqlite cpu_flags_x86_sse2 test tk"
@@ -39,7 +42,7 @@ DEPEND="${RDEPEND}
${PYTHON_DEPS}
test? ( dev-python/pytest )"
-S="${WORKDIR}/${P}-src"
+S="${WORKDIR}/${MY_P}-src"
pkg_pretend() {
if [[ ${MERGE_TYPE} != binary ]]; then
@@ -100,7 +103,7 @@ src_prepare() {
# apply CPython stdlib patches
pushd lib-python/2.7 > /dev/null || die
- epatch "${FILESDIR}"/2.5.0_all_distutils_cxx.patch \
+ epatch "${FILESDIR}"/5.6.0_all_distutils_cxx.patch \
"${WORKDIR}"/patches/22_all_turkish_locale.patch \
"${WORKDIR}"/patches/62_all_xml.use_pyxml.patch
popd > /dev/null || die