summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-09 10:58:10 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-09 11:16:54 +0100
commite27be08d4e93cf2816362123a74e774a4897dc5c (patch)
treeaa120748c42b153c20caf5f81a20ab05e24e47f6 /dev-python/pyqrcode/pyqrcode-1.2.1-r1.ebuild
parentdev-python/pypng: Bump to 0.0.20, py3.{7,8} (diff)
downloadgentoo-e27be08d4e93cf2816362123a74e774a4897dc5c.tar.gz
gentoo-e27be08d4e93cf2816362123a74e774a4897dc5c.tar.bz2
gentoo-e27be08d4e93cf2816362123a74e774a4897dc5c.zip
dev-python/pyqrcode: Modernize, enable tests, py3.{7,8}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyqrcode/pyqrcode-1.2.1-r1.ebuild')
-rw-r--r--dev-python/pyqrcode/pyqrcode-1.2.1-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pyqrcode/pyqrcode-1.2.1-r1.ebuild b/dev-python/pyqrcode/pyqrcode-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..50803e75ddd8
--- /dev/null
+++ b/dev-python/pyqrcode/pyqrcode-1.2.1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+# upstream doesn't do tags
+EGIT_COMMIT="674a77b5eaf850d063f518bd90c243ee34ad6b5d"
+
+DESCRIPTION="A pure Python QR code generator with SVG, EPS, PNG and terminal output"
+HOMEPAGE="https://github.com/mnooner256/pyqrcode https://pypi.org/project/PyQRCode/"
+SRC_URI="https://github.com/mnooner256/pyqrcode/archive/${EGIT_COMMIT}.tar.gz -> ${P}.gh.tar.gz"
+S=${WORKDIR}/${PN}-${EGIT_COMMIT}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm ~arm64 x86 ~amd64-linux ~x86-linux"
+IUSE="png"
+
+RDEPEND="
+ png? ( dev-python/pypng[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? ( dev-python/pypng[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests nose
+
+src_prepare() {
+ # don't pull in tkinter for one test
+ sed -i -e 's:test_xbm_with_tkinter:_&:' \
+ tests/test_xbm.py || die
+
+ distutils-r1_src_prepare
+}