summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-01 17:21:59 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-01 17:53:33 +0200
commit820e521f81d309c64c9aeaa2a4e1b7fef855fa09 (patch)
treee40d29c7a6f92c62e477ee5d522f43a4fa5e55b2 /dev-python/pyqtgraph
parentdev-python/coverage: Bump to 6.5.0 (diff)
downloadgentoo-820e521f81d309c64c9aeaa2a4e1b7fef855fa09.tar.gz
gentoo-820e521f81d309c64c9aeaa2a4e1b7fef855fa09.tar.bz2
gentoo-820e521f81d309c64c9aeaa2a4e1b7fef855fa09.zip
dev-python/pyqtgraph: Bump to 0.13.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyqtgraph')
-rw-r--r--dev-python/pyqtgraph/Manifest1
-rw-r--r--dev-python/pyqtgraph/pyqtgraph-0.13.1.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/pyqtgraph/Manifest b/dev-python/pyqtgraph/Manifest
index 6066acd8775b..1e0ca0e74d24 100644
--- a/dev-python/pyqtgraph/Manifest
+++ b/dev-python/pyqtgraph/Manifest
@@ -1,2 +1,3 @@
DIST pyqtgraph-0.12.4.tar.gz 1333052 BLAKE2B 4208787d1d203904d841493e10b2f1d23357b60475c9e1cfff733fe772973d4dd619ca84941049bd60299912f3077fb18c27a90fa3c0c0e712a3715b5be1d071 SHA512 8402b38fe1abaaf55d6dbc26775093993b9f642d7a9da59d2780ed38562c8653ab872c588d2e66373434491b8f397533cb3c222382065c812a28cf6b9ce34960
+DIST pyqtgraph-0.13.1.gh.tar.gz 1368154 BLAKE2B cb19ae6564b0fc0a4ec4fb6232f7949bb5130345380a86f0cffdee14e767d306b27c26ae3f7c011d77f21353b511d99148e1acb38e8d33598dde16362475b5a8 SHA512 bcd3d0c9c1d91ad2ea3f85f8e34e68ab999fce636ed336362253f09a7863a62c4b635d71c137c9458532c7d1f76dfc8433d476cd84121cf89488fb0860039b8f
DIST pyqtgraph-test-data-8.tar.gz 306068 BLAKE2B f3aa418dfaf2e74950fa880da4b6dfb4ef5dbd46346b78065d885c1f9fc06fc3de86756af17e27035d4cd47d98cc7ce58c036b493837b568086a4ebceb230c78 SHA512 07ef414f2b57e00589f8c18459e88ab16001c7cc3766164cdfcd69faa26cbc90ed64611fd0c5e3b401dc6a3f1a6e9e4ce6a7d9fa96ebcc4360e03fa9fbb856d2
diff --git a/dev-python/pyqtgraph/pyqtgraph-0.13.1.ebuild b/dev-python/pyqtgraph/pyqtgraph-0.13.1.ebuild
new file mode 100644
index 000000000000..ef091c06b4da
--- /dev/null
+++ b/dev-python/pyqtgraph/pyqtgraph-0.13.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="A pure-python graphics and GUI library built on PyQt and numpy"
+HOMEPAGE="
+ https://www.pyqtgraph.org/
+ https://github.com/pyqtgraph/pyqtgraph/
+ https://pypi.org/project/pyqtgraph/
+"
+SRC_URI="
+ https://github.com/pyqtgraph/pyqtgraph/archive/${P}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/${PN}-${P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="opengl svg"
+REQUIRED_USE="test? ( opengl svg )"
+
+RDEPEND="
+ >=dev-python/numpy-1.17[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/PyQt5[gui,widgets,opengl=,svg=,${PYTHON_USEDEP}]
+ opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? (
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/PyQt5[testlib,${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/pytest-xvfb[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_sphinx doc/source
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ if ! use opengl; then
+ rm -r pyqtgraph/opengl || die
+ fi
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # apparently fragile
+ tests/test_reload.py::test_reload
+
+ # TODO
+ tests/graphicsItems/test_ROI.py::test_PolyLineROI
+
+ # pyside2 is normally skipped if not installed but these two
+ # fail if it is installed
+ # TODO: this could be due to USE flags, revisit when pyside2
+ # gains py3.9
+ 'pyqtgraph/examples/test_examples.py::testExamples[ DateAxisItem_QtDesigner.py - PySide2 ]'
+ 'pyqtgraph/examples/test_examples.py::testExamples[ designerExample.py - PySide2 ]'
+ )
+
+ epytest -p xvfb -n "$(makeopts_jobs)"
+}