summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-06 11:19:45 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-07 20:43:26 +0200
commitbb3c9b713e74c4305626948c02664a573834c561 (patch)
tree6f0dd38be81fb3107ae479e2bf576858d04ba0c2 /dev-python/pyramid/pyramid-1.5.8.ebuild
parentdev-python/pyramid: Fix deps, enable tests (diff)
downloadgentoo-bb3c9b713e74c4305626948c02664a573834c561.tar.gz
gentoo-bb3c9b713e74c4305626948c02664a573834c561.tar.bz2
gentoo-bb3c9b713e74c4305626948c02664a573834c561.zip
dev-python/pyramid: Bump to 1.5.8 (to fix tests)
Diffstat (limited to 'dev-python/pyramid/pyramid-1.5.8.ebuild')
-rw-r--r--dev-python/pyramid/pyramid-1.5.8.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pyramid/pyramid-1.5.8.ebuild b/dev-python/pyramid/pyramid-1.5.8.ebuild
new file mode 100644
index 000000000000..99de90acd49b
--- /dev/null
+++ b/dev-python/pyramid/pyramid-1.5.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A small open source Python web framework"
+HOMEPAGE="http://www.pylonsproject.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/chameleon[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]
+ dev-python/repoze-lru[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/zope-deprecation[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ dev-python/translationstring[${PYTHON_USEDEP}]
+ dev-python/pastedeploy[${PYTHON_USEDEP}]
+ dev-python/venusian[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/webtest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep \
+ 'dev-python/zope-component[${PYTHON_USEDEP}]' \
+ 'python2*' pypy)
+ )"
+
+python_test() {
+ esetup.py test
+}