summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-09-18 13:51:16 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-09-19 01:58:53 +0200
commit30b69e600706f7f99fdfef08a314b55b4399ad90 (patch)
tree1d2e8bb7315cc1838085ded6f5a92dd56cc27662 /dev-python/pyrfc3339
parentdev-python/fakeredis: Keyword 1.4.3 arm, #741472 (diff)
downloadgentoo-30b69e600706f7f99fdfef08a314b55b4399ad90.tar.gz
gentoo-30b69e600706f7f99fdfef08a314b55b4399ad90.tar.bz2
gentoo-30b69e600706f7f99fdfef08a314b55b4399ad90.zip
dev-python/pyrfc3339: add Python 3.9 support
Use distutils_enable_tests, remove explicit setuptools dependency. Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/pyrfc3339')
-rw-r--r--dev-python/pyrfc3339/pyrfc3339-1.1.ebuild15
1 files changed, 4 insertions, 11 deletions
diff --git a/dev-python/pyrfc3339/pyrfc3339-1.1.ebuild b/dev-python/pyrfc3339/pyrfc3339-1.1.ebuild
index 1fe1a474587b..ab4cd2d80629 100644
--- a/dev-python/pyrfc3339/pyrfc3339-1.1.ebuild
+++ b/dev-python/pyrfc3339/pyrfc3339-1.1.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=(python{3_6,3_7,3_8})
+
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
MY_PN=pyRFC3339
@@ -11,20 +12,12 @@ MY_P=${MY_PN}-${PV}
DESCRIPTION="Generates and parses RFC 3339 timestamps"
HOMEPAGE="https://github.com/kurtraschke/pyRFC3339"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]"
-DEPEND="test? ( ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}] )
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-S=${WORKDIR}/${MY_P}
-python_test() {
- nosetests || die
-}
+distutils_enable_tests nose