summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2019-06-16 16:04:38 +0200
committerMatthew Thode <prometheanfire@gentoo.org>2019-06-16 13:54:14 -0500
commit55748eff1fd2b6ff30a5d9d5fb57ac13ba12decd (patch)
tree1f70caa1200eb03945312dd5ed1e5b0e78a6a599 /dev-python/pyroute2
parentx11-misc/xwallpaper: drop old (diff)
downloadgentoo-55748eff1fd2b6ff30a5d9d5fb57ac13ba12decd.tar.gz
gentoo-55748eff1fd2b6ff30a5d9d5fb57ac13ba12decd.tar.bz2
gentoo-55748eff1fd2b6ff30a5d9d5fb57ac13ba12decd.zip
dev-python/pyroute2: add missing PYTHON_REQ_USE="sqlite"
Closes: https://github.com/gentoo/gentoo/pull/12267 Signed-off-by: Henning Schild <henning@hennsch.de> Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/pyroute2')
-rw-r--r--dev-python/pyroute2/pyroute2-0.5.5-r1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/pyroute2/pyroute2-0.5.5-r1.ebuild b/dev-python/pyroute2/pyroute2-0.5.5-r1.ebuild
new file mode 100644
index 000000000000..c144bf26f0c9
--- /dev/null
+++ b/dev-python/pyroute2/pyroute2-0.5.5-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="A pure Python netlink and Linux network configuration library."
+HOMEPAGE="https://github.com/svinota/pyroute2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""