summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-04-29 16:46:56 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-04-29 16:47:08 -0700
commit6f7a9fb3f96913f9c6fd423496e7d8c5f1cd7cb6 (patch)
tree37b7590ea8fc024aca8f4dd76d7ec7f551e626a4 /dev-python/pyroute2
parentdev-perl/Authen-Radius: Bump to version 0.310.0 (diff)
downloadgentoo-6f7a9fb3f96913f9c6fd423496e7d8c5f1cd7cb6.tar.gz
gentoo-6f7a9fb3f96913f9c6fd423496e7d8c5f1cd7cb6.tar.bz2
gentoo-6f7a9fb3f96913f9c6fd423496e7d8c5f1cd7cb6.zip
dev-python/pyroute2-0.5.12: version bump, add py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/pyroute2')
-rw-r--r--dev-python/pyroute2/Manifest1
-rw-r--r--dev-python/pyroute2/files/pyroute2-0.5.12-readme-filename.patch13
-rw-r--r--dev-python/pyroute2/pyroute2-0.5.12.ebuild35
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pyroute2/Manifest b/dev-python/pyroute2/Manifest
index dc2b61ac657f..8d9af855b1c1 100644
--- a/dev-python/pyroute2/Manifest
+++ b/dev-python/pyroute2/Manifest
@@ -1 +1,2 @@
+DIST pyroute2-0.5.12.tar.gz 425500 BLAKE2B 2b8f919bc7fc9caea9f4dd41b110e8a321406de998598408bbd12d6d62fcae009d01511271e462a4118311f12c54bf51696c0334da2ce9cb185688e35994b0a8 SHA512 6115826a43f6392a727fe2dde0dd24317f35c3a7af5e45459766c3fbe9853540c68f9a9a2233c266e866f3decd22dab0032117f687758f69b962ac6606d4cbdf
DIST pyroute2-0.5.5.tar.gz 702481 BLAKE2B 7d9db1efe0d76e5fbca3f07d0ce666f919001fa26c220bd432c719aa6fc3a4d0148ea6357ed84cd5d0a6e47069994f35d2501365115b9c497674159098c2e5e5 SHA512 c7166e667b6fd21eefd34a01a0bba8467f3ae4d9526af32d5a6e96747c8aac7590da1097f1ca9b12390158e90ddfd6ff9f68c85765abbe179e8761658dda6b86
diff --git a/dev-python/pyroute2/files/pyroute2-0.5.12-readme-filename.patch b/dev-python/pyroute2/files/pyroute2-0.5.12-readme-filename.patch
new file mode 100644
index 000000000000..9fa7379e565c
--- /dev/null
+++ b/dev-python/pyroute2/files/pyroute2-0.5.12-readme-filename.patch
@@ -0,0 +1,13 @@
+diff --git a/setup.py b/setup.py
+index 5c387f01..b0f1449e 100644
+--- a/setup.py
++++ b/setup.py
+@@ -23,7 +23,7 @@ module = __import__(config.get('setup', 'setuplib'),
+ ['setup'], 0)
+ setup = getattr(module, 'setup')
+
+-readme = open("README.md", "r")
++readme = open("README.rst", "r")
+
+
+ setup(name='pyroute2',
diff --git a/dev-python/pyroute2/pyroute2-0.5.12.ebuild b/dev-python/pyroute2/pyroute2-0.5.12.ebuild
new file mode 100644
index 000000000000..09505762e110
--- /dev/null
+++ b/dev-python/pyroute2/pyroute2-0.5.12.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="A pure Python netlink and Linux network configuration library."
+HOMEPAGE="https://github.com/svinota/pyroute2"
+SRC_URI="https://github.com/svinota/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )
+"
+
+RESTRICT="!test? ( test )"
+
+# tests need root access
+RESTRICT+=" test"
+
+PATCHES=(
+ "${FILESDIR}/pyroute2-0.5.12-readme-filename.patch"
+)
+
+distutils_enable_tests nose